summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-14 17:25:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:47 -0400
commitefb791ba4f3559ca9306289889af02da96b822f3 (patch)
treef25400f08d6a1708d6e7b97f09c9812aae45a971 /gnu/packages
parent7e679ea7f71abf233512c30cf2a951dfe3f03f6b (diff)
downloadguix-patches-efb791ba4f3559ca9306289889af02da96b822f3.tar
guix-patches-efb791ba4f3559ca9306289889af02da96b822f3.tar.gz
gnu: python-sphinx: Propagate TexLive dependencies.
* gnu/packages/sphinx.scm (python-sphinx): [propagated-inputs]: Add texlive-amsfonts, texlive-amsmath, texlive-capt-of, texlive-carlisle, texlive-etoolbox, texlive-generic-ltxcmds, texlive-hyperref, texlive-latex-base, texlive-latex-cmap, texlive-latex-fancyhdr, texlive-latex-fancyvrb, texlive-latex-fncychap, texlive-latex-float, texlive-latex-framed, texlive-latex-geometry, texlive-latex-graphics, texlive-latex-kvoptions, texlive-latex-needspace, texlive-latex-parskip, texlive-latex-preview, texlive-latex-tabulary, texlive-latex-titlesec, texlive-latex-tools, texlive-latex-upquote, texlive-latex-varwidth, texlive-oberdiek, texlive-stringenc, texlive-wrapfig, texlive-xcolor and texlive-zapfding. [native-inputs]: Remove graphviz, python-mock and python-nose. * gnu/packages/tex.scm (texlive-xcolor): Add TODO comment. * gnu/packages/tex.scm (texlive-hyperref): Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sphinx.scm47
-rw-r--r--gnu/packages/tex.scm11
2 files changed, 50 insertions, 8 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 69a92b8b97..a377729397 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,7 +54,8 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages time)
#:use-module (gnu packages python-science)
- #:use-module (gnu packages graph))
+ #:use-module (gnu packages graph)
+ #:use-module (gnu packages tex))
(define-public python-sphinx
(package
@@ -95,13 +96,45 @@
python-sphinxcontrib-htmlhelp
python-sphinxcontrib-jsmath
python-sphinxcontrib-qthelp
- python-sphinxcontrib-serializinghtml))
+ python-sphinxcontrib-serializinghtml
+
+ ;; The Sphinx LaTeX library '\RequirePackage' or \\usepackage
+ ;; these:
+ texlive-amsfonts ;amsmath, amssymb, amstext
+ texlive-amsmath
+ texlive-capt-of
+ texlive-carlisle ;remreset
+ texlive-etoolbox
+ texlive-generic-ltxcmds
+ texlive-hyperref
+ ;; TODO: Remove texlive-stringenc and texlive-zapfding after
+ ;; propagating them in texlive-hyperref in next rebuild cycle.
+ texlive-stringenc
+ texlive-zapfding
+ texlive-latex-base ;alltt, atbegshi, makeidx, textcomp
+ texlive-latex-cmap
+ texlive-latex-fancyhdr
+ texlive-latex-fancyvrb
+ texlive-latex-float
+ texlive-latex-fncychap
+ texlive-latex-framed
+ texlive-latex-geometry
+ texlive-latex-graphics ;graphicx, color
+ texlive-latex-kvoptions
+ texlive-latex-needspace
+ texlive-latex-parskip
+ texlive-latex-preview
+ texlive-latex-tabulary
+ texlive-latex-titlesec
+ texlive-latex-tools ;multicol, longtable
+ texlive-latex-upquote
+ texlive-latex-varwidth
+ texlive-oberdiek ;hypcap
+ texlive-wrapfig
+ texlive-xcolor))
(native-inputs
- (list graphviz
- imagemagick ;for "convert"
+ (list imagemagick ;for "convert"
python-html5lib
- python-mock
- python-nose
python-pytest))
(home-page "https://www.sphinx-doc.org")
(synopsis "Python documentation generator")
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a861b40950..0aa6a8bf95 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3326,6 +3326,9 @@ used by @code{hyperref} and @code{bookmark}.")
(rename-file (string-append share "/tex/latex/xcolor/xcolor.pro")
(string-append share "/dvips/xcolor/xcolor.pro"))
#t)))))))
+ ;; TODO: Propagate texlive-hyperref and many others in the next rebuild
+ ;; cycle. Grep for '\usepackage' to see what packages it requires.
+ ;; (propagated-inputs (list texlive-hyperref ...))
(home-page "https://www.ctan.org/pkg/xcolor")
(synopsis "Driver-independent color extensions for LaTeX and pdfLaTeX")
(description
@@ -3449,7 +3452,13 @@ XML, using UTF-8 or a suitable 8-bit encoding.")
texlive-latex-pdftexcmds
texlive-latex-refcount
texlive-latex-rerunfilecheck
- texlive-url))
+ texlive-url
+ ;; TODO: Add this in next rebuild cycle.
+ ;;texlive-cm
+ ;;texlive-latex-graphics ;for keyval
+ ;;texlive-stringenc
+ ;;texlive-zapfding
+ ))
(home-page "https://www.ctan.org/pkg/hyperref")
(synopsis "Extensive support for hypertext in LaTeX")
(description