summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-13 23:14:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:47 +0200
commitc87d8a140539abe9a86cbf0461ddb32dfeb92b39 (patch)
tree1a73bff0a7d4a382c0c9fd3341dce7815ba7ce01 /gnu/packages/tex.scm
parent10e8b3385c54991b5ec21eb817ef44774d8e8fee (diff)
downloadguix-patches-c87d8a140539abe9a86cbf0461ddb32dfeb92b39.tar
guix-patches-c87d8a140539abe9a86cbf0461ddb32dfeb92b39.tar.gz
gnu: Add texlive-ruhyphen.
* gnu/packages/tex.scm (texlive-ruhyphen): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 47508108b3..94abbf8ded 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -66,6 +66,7 @@
#:use-module (gnu packages ruby)
#:use-module (gnu packages shells)
#:use-module (gnu packages base)
+ #:use-module (gnu packages gawk)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -2512,6 +2513,45 @@ Ukrainian, depending on the encoding of the output font including the standard
T2A.")
(license license:lppl)))
+(define-public texlive-ruhyphen
+ (let ((template (simple-texlive-package
+ "texlive-ruhyphen"
+ (list "/source/generic/ruhyphen/"
+ "/tex/generic/ruhyphen/")
+ (base32
+ "18n1bqhh8jv765vz3a3fjwffy7m71vhwx9yq8zl0p5j7p72q9qcn")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'build
+ (lambda _
+ (let ((cwd (getcwd)))
+ ;; Remove generated files.
+ (for-each delete-file
+ (find-files "tex/generic/ruhyphen/"
+ "^cyry.*.tex$"))
+ (substitute* "source/generic/ruhyphen/Makefile"
+ (("./mkcyryo") (string-append cwd "/source/generic/ruhyphen/mkcyryo")))
+ (with-directory-excursion "tex/generic/ruhyphen"
+ (invoke "make" "-f"
+ (string-append cwd "/source/generic/ruhyphen/Makefile"))))))))))
+ (native-inputs
+ `(("coreutils" ,coreutils)
+ ("gawk" ,gawk)
+ ("sed" ,sed)
+ ("grep" ,grep)
+ ("perl" ,perl)))
+ (home-page "https://www.ctan.org/pkg/ruhyphen")
+ (synopsis "Hyphenation patterns for Russian")
+ (description "The package provides a collection of Russian hyphenation
+patterns supporting a number of Cyrillic font encodings, including T2,
+UCY (Omega Unicode Cyrillic), LCY, LWN (OT2), and koi8-r.")
+ (license license:lppl))))
+
(define-public texlive-latex-base
(let ((texlive-dir
(lambda (dir hash)