summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-17 15:19:39 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-26 22:55:06 +0200
commit32710c71df3149f94827e3919c50f74de4f8bc38 (patch)
tree0cfe75c9257d66af9596d391fba562862fc323f6 /gnu/packages/tex.scm
parent452b7a75109182a7eb1a7791859f4fd076f81853 (diff)
downloadguix-patches-32710c71df3149f94827e3919c50f74de4f8bc38.tar
guix-patches-32710c71df3149f94827e3919c50f74de4f8bc38.tar.gz
gnu: Add texlive-latex-ebproof.
* gnu/packages/tex.scm (texlive-latex-ebproof): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index da19a57e59..086d6190dd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8546,6 +8547,35 @@ theorems. The package supports saving and reuse of source code and text
parts.")
(license license:lppl1.3c+))))
+(define-public texlive-latex-ebproof
+ (package
+ (name "texlive-latex-ebproof")
+ (version "2.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://framagit.org/manu/ebproof")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zkrfaf343js0yc1x7m3d8hzbh5izn0lb01jrmdpjm51kdbh30xq"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/ebproof"))
+ (propagated-inputs
+ `(("texlive-latex-l3kernel" ,texlive-latex-l3kernel)))
+ (home-page "http://www.ctan.org/pkg/ebproof")
+ (synopsis
+ "Formal proofs in the style of sequent calculus")
+ (description
+ "This package provides commands to typeset proof trees in the style of
+sequent calculus and related systems. The commands allow for writing
+inferences with any number of premises and alignment of successive formulas on
+an arbitrary point. Various options allow complete control over spacing,
+styles of inference rules, placement of labels, etc.")
+ (license license:lppl1.3+)))
+
(define-public texlive-eurosym
(let ((template (simple-texlive-package
"texlive-eurosym"