summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index da19a57e59..086d6190dd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8546,6 +8547,35 @@ theorems. The package supports saving and reuse of source code and text
parts.")
(license license:lppl1.3c+))))
+(define-public texlive-latex-ebproof
+ (package
+ (name "texlive-latex-ebproof")
+ (version "2.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://framagit.org/manu/ebproof")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zkrfaf343js0yc1x7m3d8hzbh5izn0lb01jrmdpjm51kdbh30xq"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/ebproof"))
+ (propagated-inputs
+ `(("texlive-latex-l3kernel" ,texlive-latex-l3kernel)))
+ (home-page "http://www.ctan.org/pkg/ebproof")
+ (synopsis
+ "Formal proofs in the style of sequent calculus")
+ (description
+ "This package provides commands to typeset proof trees in the style of
+sequent calculus and related systems. The commands allow for writing
+inferences with any number of premises and alignment of successive formulas on
+an arbitrary point. Various options allow complete control over spacing,
+styles of inference rules, placement of labels, etc.")
+ (license license:lppl1.3+)))
+
(define-public texlive-eurosym
(let ((template (simple-texlive-package
"texlive-eurosym"