summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-01-11 19:09:47 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-26 19:17:01 +0100
commitb630967247daaba4949a1b69f83344e1ad13e660 (patch)
treef8afd835313565c88ebf3f839b3a2791e5de0be9 /gnu/packages/telephony.scm
parent1bfcb19bc3009f8619476f83a84ea3945878798a (diff)
downloadguix-patches-b630967247daaba4949a1b69f83344e1ad13e660.tar
guix-patches-b630967247daaba4949a1b69f83344e1ad13e660.tar.gz
gnu: Add libringclient.
* gnu/packages/telephony.scm (libringclient): New variable.
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 5e11217e3f..29ba0f01ee 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -802,3 +802,39 @@ This package provides a library and daemon implementing the Jami core
functionality.")
(home-page "https://jami.net/")
(license license:gpl3+)))
+
+(define-public libringclient
+ (package
+ (inherit libring)
+ (name "libringclient")
+ (build-system cmake-build-system)
+ (propagated-inputs
+ `(("libring" ,libring) ; For 'dring'.
+ ("qtbase" ,qtbase) ; Qt is included in several installed headers.
+ ("qttools" ,qttools)))
+ (arguments
+ `(#:tests? #f ; There is no testsuite.
+ #:configure-flags
+ (list (string-append "-DRING_BUILD_DIR="
+ (assoc-ref %build-inputs "libring") "/include"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "lrc")
+ #t))
+ (add-before 'configure 'fix-dbus-interfaces-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{CMAKE_INSTALL_PREFIX\\}(/share/dbus-1/interfaces)" _ dbus-interfaces-path-suffix)
+ (string-append (assoc-ref inputs "libring")
+ dbus-interfaces-path-suffix))))))))
+ (synopsis "Distributed multimedia communications platform")
+ (description "Jami (formerly GNU Ring) is a secure and distributed voice,
+video and chat communication platform that requires no centralized server and
+leaves the power of privacy in the hands of the user. It supports the SIP and
+IAX protocols, as well as decentralized calling using P2P-DHT.
+
+This package provides a library common to all Jami clients.")
+ (home-page "https://jami.net")
+ (license license:gpl3+)))