summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-01-11 18:58:31 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-26 19:17:01 +0100
commit1bfcb19bc3009f8619476f83a84ea3945878798a (patch)
treecd2583774d7f9368d42bc712b14219150ccdbf3a /gnu/packages/telephony.scm
parent915829e6622f274ec058fdf78acf87e7d31bf0d6 (diff)
downloadguix-patches-1bfcb19bc3009f8619476f83a84ea3945878798a.tar
guix-patches-1bfcb19bc3009f8619476f83a84ea3945878798a.tar.gz
gnu: Add libring.
* gnu/packages/telephony.scm (libring): New variable.
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm74
1 files changed, 74 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 9579362795..5e11217e3f 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -728,3 +728,77 @@ Initiation Protocol (SIP) and a multimedia framework.")
(("selftest: pjlib-test pjlib-util-test pjnath-test pjmedia-test pjsip-test pjsua-test")
"selftest: pjlib-test pjlib-util-test pjmedia-test"))
#t)))))))
+
+(define-public libring
+ (package
+ (name "libring")
+ (version %jami-version)
+ (source (jami-source #:without-daemon #t))
+ (build-system gnu-build-system)
+ (inputs
+ ;; Missing (optional?) dep: libnatpmp.
+ `(("alsa-lib" ,alsa-lib)
+ ("boost" ,boost)
+ ("dbus-c++" ,dbus-c++)
+ ("eudev" ,eudev)
+ ("ffmpeg" ,ffmpeg)
+ ("flac" ,flac)
+ ("gmp" ,gmp)
+ ("gsm" ,gsm)
+ ("jack" ,jack-1)
+ ("jsoncpp" ,jsoncpp)
+ ("libogg" ,libogg)
+ ("libva" ,libva)
+ ("opendht" ,opendht)
+ ("opus" ,opus)
+ ("pcre" ,pcre)
+ ("pulseaudio" ,pulseaudio)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("speex" ,speex)
+ ("speexdsp" ,speexdsp)
+ ("libupnp" ,libupnp)
+ ("libvorbis" ,libvorbis)
+ ("libx264" ,libx264)
+ ("libvdpau" ,libvdpau)
+ ("yaml-cpp" ,yaml-cpp)
+ ("zlib" ,zlib)
+ ("openssl" ,openssl)
+ ("libsecp256k1" ,libsecp256k1)
+ ("python" ,python)
+ ("python-wrapper" ,python-wrapper)
+ ("restbed" ,restbed)
+ ("libx11" ,libx11)
+ ;; TODO: Upstream seems to rely on a custom pjproject (a.k.a. pjsip) version.
+ ;; See https://git.jami.net/savoirfairelinux/ring-daemon/issues/24.
+ ("pjproject" ,pjproject-jami)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)
+ ("cppunit" ,cppunit)
+ ("perl" ,perl))) ; Needed for documentation.
+ (arguments
+ `(#:tests? #f ; The tests fail to compile due to missing headers.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "daemon")
+ #t))
+ (add-before 'build 'add-lib-dir
+ (lambda _
+ (mkdir-p "src/lib")
+ #t)))))
+ (synopsis "Distributed multimedia communications platform")
+ (description "Jami (formerly GNU Ring) is a secure and distributed voice,
+video and chat communication platform that requires no centralized server and
+leaves the power of privacy in the hands of the user. It supports the SIP and
+IAX protocols, as well as decentralized calling using P2P-DHT.
+
+This package provides a library and daemon implementing the Jami core
+functionality.")
+ (home-page "https://jami.net/")
+ (license license:gpl3+)))