summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-04 12:41:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-04 20:54:37 +0100
commit0c45a6a4c85d5cef12973714a26f478832533425 (patch)
tree96c4e62d12fb1c3c6d5c4f30b8481a8cab319d1b /gnu/packages/telephony.scm
parent80e2524c9a6ff4a1e89099c09627e35c5b0d2e7a (diff)
downloadguix-patches-0c45a6a4c85d5cef12973714a26f478832533425.tar
guix-patches-0c45a6a4c85d5cef12973714a26f478832533425.tar.gz
gnu: Add ortp.
* gnu/packages/telephony.scm (ortp): New variable.
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 6fd40d6179..cf1ab93c39 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -272,6 +272,29 @@ and a supporting cryptographic kernel.")
Communications softwares like linphone.")
(license license:gpl2+)))
+(define-public ortp
+ (package
+ (name "ortp")
+ (version "0.27.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.savannah.nongnu.org/"
+ "releases/linphone/ortp/sources/ortp-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1by0dqdqrj5avzcvjws30g8v5sa61wj12x00sxw0kn1smcrshqgb"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("bctoolbox" ,bctoolbox)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://linphone.org/")
+ (synopsis "Implementation of the Real-time transport protocol")
+ (description "oRTP is a library implementing the Real-time transport
+protocol (RFC 3550).")
+ (license license:lgpl2.1+)))
+
(define-public libiax2
(let ((commit "0e5980f1d78ce462e2d1ed6bc39ff35c8341f201"))
;; This is the commit used by the Ring Project.