summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-04 12:40:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-04 20:54:37 +0100
commit80e2524c9a6ff4a1e89099c09627e35c5b0d2e7a (patch)
treed5d2894b827a73f0958f6b819067efeced496846 /gnu/packages/telephony.scm
parenta64d9d56a3d32985c43c9f0fd7829bb105a7bee2 (diff)
downloadguix-patches-80e2524c9a6ff4a1e89099c09627e35c5b0d2e7a.tar
guix-patches-80e2524c9a6ff4a1e89099c09627e35c5b0d2e7a.tar.gz
gnu: Add bctoolbox.
* gnu/packages/telephony.scm (bctoolbox): New variable.
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 5df5e9e4ab..6fd40d6179 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Francesco Frassinelli <fraph24@gmail.com>
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +28,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages linux)
@@ -247,6 +249,29 @@ and a supporting cryptographic kernel.")
(home-page "https://github.com/cisco/libsrtp")
(license license:bsd-3)))
+(define-public bctoolbox
+ (package
+ (name "bctoolbox")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/linphone/bctoolbox/bctoolbox-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "14ivv6bh6qywys6yyb34scy9w78d636xl1f7cyxm3gwx2qv71lx5"))))
+ (build-system gnu-build-system)
+ (arguments '(#:make-flags '("CFLAGS=-fPIC")))
+ (native-inputs
+ `(("cunit" ,cunit)))
+ (inputs
+ `(("mbedtls" ,mbedtls-apache)))
+ (home-page "https://www.linphone.org")
+ (synopsis "Utilities library for linphone software")
+ (description "BCtoolbox is a utilities library used by Belledonne
+Communications softwares like linphone.")
+ (license license:gpl2+)))
+
(define-public libiax2
(let ((commit "0e5980f1d78ce462e2d1ed6bc39ff35c8341f201"))
;; This is the commit used by the Ring Project.