summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-11-06 18:10:09 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-11-12 10:29:37 +0100
commitd4780c82387f226658bc8bf073ce8610bf37433b (patch)
treed42581fefa6e0cae18267bd46e8133d5936548e4 /gnu/packages/syncthing.scm
parent46a37b5966298e26d91d2a660c3f2c84f111f826 (diff)
downloadguix-patches-d4780c82387f226658bc8bf073ce8610bf37433b.tar
guix-patches-d4780c82387f226658bc8bf073ce8610bf37433b.tar.gz
gnu: go-github-com-audriusbutkevicius-cli: Fix tests for go-1.11.
* gnu/packages/syncthing.scm (go-github-com-audriusbutkevicius-cli): Fix tests for go-1.11.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 46211d27d8..7e4ff0ed84 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -900,7 +900,16 @@ the current goroutine's ID.")
"0bg26pfg25vr16jmczig2m493mja2nxjxyswz3hha7avxw20rpi5"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/AudriusButkevicius/cli"))
+ '(#:import-path "github.com/AudriusButkevicius/cli"
+ ;; Tests don't pass "vet" on go-1.11. See
+ ;; https://github.com/AudriusButkevicius/cli/pull/1.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key import-path #:allow-other-keys)
+ (invoke "go" "test"
+ "-vet=off"
+ import-path))))))
(synopsis "Library for building command-line interfaces in Go")
(description "This package provides a library for building command-line
interfaces in Go.")