summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-11-06 18:09:16 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-11-12 10:29:31 +0100
commit46a37b5966298e26d91d2a660c3f2c84f111f826 (patch)
tree17d822397fd64a855da62f34c46ebca5c9879748 /gnu/packages/syncthing.scm
parent0fd115d536d59e5160329546f09943c278b15cdb (diff)
downloadguix-patches-46a37b5966298e26d91d2a660c3f2c84f111f826.tar
guix-patches-46a37b5966298e26d91d2a660c3f2c84f111f826.tar.gz
gnu: go-github-com-prometheus-common-expfmt: Fix tests for go-1.11.
* gnu/packages/syncthing.scm (go-github-com-prometheus-common-expfmt): Fix tests for go-1.11.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5d681b816e..46211d27d8 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1097,7 +1097,14 @@ message streaming.")
(string-append (assoc-ref outputs "out")
"/src/github.com/prometheus/common/expfmt/testdata/")
".*\\.gz$"))
- #t)))))
+ #t))
+ (replace 'check
+ ;; Tests don't pass "vet" on go-1.11. See
+ ;; https://github.com/syncthing/syncthing/issues/5311.
+ (lambda* (#:key import-path #:allow-other-keys)
+ (invoke "go" "test"
+ "-vet=off"
+ import-path))))))
(propagated-inputs
`(("go-github-com-golang-protobuf-proto"
,go-github-com-golang-protobuf-proto)