summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-13 17:31:24 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:30 -0400
commitbafdb0fa0994006c4974b4762031af91b233beda (patch)
tree8bd41a0385bb5ef4e7b60b4a82e97a4f88244a8d /gnu/packages/syncthing.scm
parentfef131b4604ca4a9d9b395c16d1c87f1ff32a1c0 (diff)
downloadguix-patches-bafdb0fa0994006c4974b4762031af91b233beda.tar
guix-patches-bafdb0fa0994006c4974b4762031af91b233beda.tar.gz
gnu: Add go-github-com-prometheus-common-model.
* gnu/packages/syncthing.scm (go-github-com-prometheus-common-model): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 20933b3b8c..708eae9850 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1000,6 +1000,31 @@ Prometheus metrics.")
(home-page "https://github.com/prometheus/common")
(license asl2.0))))
+(define-public go-github-com-prometheus-common-model
+ (let ((commit "2e54d0b93cba2fd133edc32211dcc32c06ef72ca")
+ (revision "0"))
+ (package
+ (name "go-github-com-prometheus-common-model")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/common.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14kn5w7imcxxlfdqxl21fsnlf1ms7200g3ldy29hwamldv8qlm7j"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prometheus/common/model"
+ #:unpack-path "github.com/prometheus/common"))
+ (synopsis "Prometheus component")
+ (description "This package provides a component of the Go Prometheus
+implementation.")
+ (home-page "https://github.com/prometheus/common")
+ (license asl2.0))))
+
(define-public go-github-com-prometheus-procfs
(let ((commit "b15cd069a83443be3154b719d0cc9fe8117f09fb")
(revision "0"))