summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-13 17:26:19 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:30 -0400
commitfef131b4604ca4a9d9b395c16d1c87f1ff32a1c0 (patch)
tree51e8bf6d66d81c44f4aca06704ec9c6d421d255a /gnu/packages/syncthing.scm
parent7dc89dc6a1e1a66e8306aef218004677382d63fe (diff)
downloadguix-patches-fef131b4604ca4a9d9b395c16d1c87f1ff32a1c0.tar
guix-patches-fef131b4604ca4a9d9b395c16d1c87f1ff32a1c0.tar.gz
gnu: go-github-com-calmh-xdr: Update to 1.1.0.
The diff shows this package being downgraded from 2.0.1 to 1.1.0. However, '2.0.1' was a typo — it should have read 1.0.1. * gnu/packages/syncthing.scm (go-github-com-calmh-xdr): Update to 1.1.0.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c6b986c9c7..20933b3b8c 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -219,29 +219,27 @@ information, such as how much storage space is available, free, and used.")
(license public-domain)))
(define-public go-github-com-calmh-xdr
- (let ((commit "08e072f9cb164f943a92eb59f90f3abc64ac6e8f")
- (revision "0"))
- (package
- (name "go-github-com-calmh-xdr")
- (version (git-version "2.0.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/calmh/xdr")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "072wqdncz3nd4a3zkhvzzx1y3in1lm29wfvl0d8wrnqs5pyqh0mh"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/calmh/xdr"))
- (synopsis "XDR marshalling and unmarshalling")
- (description "XDR is an External Data Representation (XDR)
+ (package
+ (name "go-github-com-calmh-xdr")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/calmh/xdr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "072wqdncz3nd4a3zkhvzzx1y3in1lm29wfvl0d8wrnqs5pyqh0mh"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/calmh/xdr"))
+ (synopsis "XDR marshalling and unmarshalling")
+ (description "XDR is an External Data Representation (XDR)
marshalling and unmarshalling library in Go. It uses code generation and not
reflection.")
- (home-page "https://github.com/calmh/xdr")
- (license expat))))
+ (home-page "https://github.com/calmh/xdr")
+ (license expat)))
(define-public go-github-com-d4l3k-messagediff
(package