summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-10-08 18:39:27 -0400
committerLeo Famulari <leo@famulari.name>2020-02-13 19:44:24 -0500
commita427d7353f70113fc2671797fd4ed20d189d2ce9 (patch)
tree329ee48ffbf1d9a3eea4ce87af1b9586f6a6756b /gnu/packages/syncthing.scm
parent87abee4e537e6e2cfea6dbcedce4380c2b58049c (diff)
downloadguix-patches-a427d7353f70113fc2671797fd4ed20d189d2ce9.tar
guix-patches-a427d7353f70113fc2671797fd4ed20d189d2ce9.tar.gz
gnu: go-github-com-jackpal-gateway: Update to 1.0.5.
* gnu/packages/syncthing.scm (go-github-com-jackpal-gateway): Update to 1.0.5.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index f904a68485..8282994663 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -379,28 +379,26 @@ compression format.")
(license bsd-3))))
(define-public go-github-com-jackpal-gateway
- (let ((commit "5795ac81146e01d3fab7bcf21c043c3d6a32b006")
- (revision "0"))
- (package
- (name "go-github-com-jackpal-gateway")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jackpal/gateway")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0fkwkwmhfadwk3cha8616bhqxfkr9gjjnynhhxyldlphixgs3f25"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/jackpal/gateway"))
- (synopsis "Discover the address of a LAN gateway")
- (description "@code{gateway} is a Go library for discovering the IP
+ (package
+ (name "go-github-com-jackpal-gateway")
+ (version "1.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jackpal/gateway")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ird5xmizj632l3dq24s2xgb8w1dn6v8xznlqz252gvngyr2gjl1"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/jackpal/gateway"))
+ (synopsis "Discover the address of a LAN gateway")
+ (description "@code{gateway} is a Go library for discovering the IP
address of the default LAN gateway.")
- (home-page "https://github.com/jackpal/gateway")
- (license bsd-3))))
+ (home-page "https://github.com/jackpal/gateway")
+ (license bsd-3)))
(define-public go-github-com-lib-pq
(package