summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-17 13:36:19 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:03 -0400
commit7cb9c4e2e15ca1f13afd67d2c30d67495ebbea23 (patch)
tree1a20839103dc7456c5e261a342d231e94f63f2fd /gnu/packages/syncthing.scm
parente5906bb44054baf1e2f147d38e21fa29fdc94e81 (diff)
downloadguix-patches-7cb9c4e2e15ca1f13afd67d2c30d67495ebbea23.tar
guix-patches-7cb9c4e2e15ca1f13afd67d2c30d67495ebbea23.tar.gz
gnu: Add go-github-com-audriusbutkevicius-pfilter.
* gnu/packages/syncthing.scm (go-github-com-audriusbutkevicius-pfilter): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index bee89d57fb..1f94cdd937 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1200,3 +1200,28 @@ quoting, commenting, and escaping.")
(description "This package is an internal component of Prometheus.")
(home-page "https://github.com/prometheus/common")
(license asl2.0)))
+
+(define-public go-github-com-audriusbutkevicius-pfilter
+ (let ((commit "c55ef6137fc6f075801eac099cc2687ede0f101d")
+ (revision "3"))
+ (package
+ (name "go-github-com-audriusbutkevicius-pfilter")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AudriusButkevicius/pfilter.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xzhwyd0w21bhvzl5pinn22hp0y6h44rh3s2ppql69rafc6zd3c6"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/AudriusButkevicius/pfilter"))
+ (synopsis "Filter packets into mulitple virtual connections")
+ (description "Pfilter is a Go package for filtering packets into multiple
+virtual connections from a single physical connection.")
+ (home-page "https://github.com/AudriusButkevicius/pfilter")
+ (license expat))))