summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-11-06 18:10:42 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-11-12 10:29:43 +0100
commit66fa8f0f77ac26766e5547ffdaa67cf6c261bd8e (patch)
treed87b8a13474e8c570c035736a5a73811ca13ec4b /gnu/packages/syncthing.scm
parentd4780c82387f226658bc8bf073ce8610bf37433b (diff)
downloadguix-patches-66fa8f0f77ac26766e5547ffdaa67cf6c261bd8e.tar
guix-patches-66fa8f0f77ac26766e5547ffdaa67cf6c261bd8e.tar.gz
gnu: go-gopkg.in-asn1-ber.v1: Fix tests for go-1.11.
* gnu/packages/syncthing.scm (go-gopkg.in-asn1-ber.v1): Fix tests for go-1.11.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 7e4ff0ed84..c29c88a588 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1267,7 +1267,16 @@ Prometheus HTTP API.")
"1y8bvzbxpw0lfnn7pbcdwzqj4l90qj6xf88dvv9pxd9yl5g6cskx"))))
(build-system go-build-system)
(arguments
- '(#:import-path "gopkg.in/asn1-ber.v1"))
+ '(#:import-path "gopkg.in/asn1-ber.v1"
+ ;; Tests don't pass "vet" on go-1.11. See
+ ;; https://github.com/go-asn1-ber/asn1-ber/issues/20.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key import-path #:allow-other-keys)
+ (invoke "go" "test"
+ "-vet=off"
+ import-path))))))
(synopsis "ASN.1 BER encoding and decoding in Go")
(description "This package provides ASN.1 BER encoding and decoding in the
Go language.")