summaryrefslogtreecommitdiff
path: root/gnu/packages/storage.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-30 13:44:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-30 22:32:36 +0200
commitc3c25082e820fc3e376a757a48124924b92d816a (patch)
tree325d1977ba2dbed409bc83b474964395118fbbce /gnu/packages/storage.scm
parent2657fb6381faef616716b7fbfa514330302b2ca4 (diff)
downloadguix-patches-c3c25082e820fc3e376a757a48124924b92d816a.tar
guix-patches-c3c25082e820fc3e376a757a48124924b92d816a.tar.gz
gnu: ceph: Update to 12.0.1.
* gnu/packages/storage.scm (ceph): Update to 12.0.1. [arguments]: Disable one new test. * gnu/packages/patches/ceph-disable-cpu-optimizations.patch: Adjust context.
Diffstat (limited to 'gnu/packages/storage.scm')
-rw-r--r--gnu/packages/storage.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 8207c2b388..7288a0f790 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -48,14 +48,14 @@
(define-public ceph
(package
(name "ceph")
- (version "12.0.0")
+ (version "12.0.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.ceph.com/tarballs/ceph-"
version ".tar.gz"))
(sha256
(base32
- "0yzvwlwg85w04q4d9ac73vfpxjnl72dl6kc857ihv5k1lqbpp5d0"))
+ "1mgd7iqx9zgwims2bb8dbzhzv0p6z9vjxavbv8dampa34fzac3xc"))
(patches
(search-patches "ceph-skip-unittest_blockdev.patch"
"ceph-skip-collect-sys-info-test.patch"
@@ -204,6 +204,10 @@
;; Also remove from the set_property block.
(("run-tox-ceph-disk") "")
(("run-tox-ceph-detect-init") ""))
+ ;; TODO: This also seems to fail because of /etc/os-release.
+ ;; How to make src/common/util.cc behave without it.
+ (substitute* "src/test/crush/CMakeLists.txt"
+ (("^add_ceph_test\\(crush-classes\\.sh.*$") "\n"))
;; More 'ceph-disk' issues here.. :-(
(substitute* "src/test/erasure-code/CMakeLists.txt"
(("^add_ceph_test\\(test-erasure-code-plugins\\.sh.*$") "\n")