summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-30 13:44:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-30 22:32:36 +0200
commitc3c25082e820fc3e376a757a48124924b92d816a (patch)
tree325d1977ba2dbed409bc83b474964395118fbbce
parent2657fb6381faef616716b7fbfa514330302b2ca4 (diff)
downloadguix-patches-c3c25082e820fc3e376a757a48124924b92d816a.tar
guix-patches-c3c25082e820fc3e376a757a48124924b92d816a.tar.gz
gnu: ceph: Update to 12.0.1.
* gnu/packages/storage.scm (ceph): Update to 12.0.1. [arguments]: Disable one new test. * gnu/packages/patches/ceph-disable-cpu-optimizations.patch: Adjust context.
-rw-r--r--gnu/packages/patches/ceph-disable-cpu-optimizations.patch6
-rw-r--r--gnu/packages/storage.scm8
2 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/patches/ceph-disable-cpu-optimizations.patch b/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
index f4d258b602..6d20fe3da4 100644
--- a/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
+++ b/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
@@ -14,16 +14,16 @@ x86_64 systems. Also don't add anything for i686.
#
# SIMD_COMPILE_FLAGS
#
-@@ -41,7 +37,7 @@
+@@ -56,7 +53,7 @@
if(HAVE_ARM_NEON)
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mfpu=neon")
endif()
-elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "i386|i686|amd64|x86_64|AMD64")
+elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64|x86_64|AMD64")
- set(HAVE_INTEL 1)
+ set(HAVE_INTEL 1)
CHECK_C_COMPILER_FLAG(-msse HAVE_INTEL_SSE)
if(HAVE_INTEL_SSE)
-@@ -55,20 +51,4 @@
+@@ -70,20 +67,4 @@
if(HAVE_INTEL_SSE3)
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse3")
endif()
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 8207c2b388..7288a0f790 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -48,14 +48,14 @@
(define-public ceph
(package
(name "ceph")
- (version "12.0.0")
+ (version "12.0.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.ceph.com/tarballs/ceph-"
version ".tar.gz"))
(sha256
(base32
- "0yzvwlwg85w04q4d9ac73vfpxjnl72dl6kc857ihv5k1lqbpp5d0"))
+ "1mgd7iqx9zgwims2bb8dbzhzv0p6z9vjxavbv8dampa34fzac3xc"))
(patches
(search-patches "ceph-skip-unittest_blockdev.patch"
"ceph-skip-collect-sys-info-test.patch"
@@ -204,6 +204,10 @@
;; Also remove from the set_property block.
(("run-tox-ceph-disk") "")
(("run-tox-ceph-detect-init") ""))
+ ;; TODO: This also seems to fail because of /etc/os-release.
+ ;; How to make src/common/util.cc behave without it.
+ (substitute* "src/test/crush/CMakeLists.txt"
+ (("^add_ceph_test\\(crush-classes\\.sh.*$") "\n"))
;; More 'ceph-disk' issues here.. :-(
(substitute* "src/test/erasure-code/CMakeLists.txt"
(("^add_ceph_test\\(test-erasure-code-plugins\\.sh.*$") "\n")