summaryrefslogtreecommitdiff
path: root/gnu/packages/storage.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-11 19:49:27 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-11 19:49:27 +0100
commit63d4ef52ebad4157817d56ccbe974da8fff81929 (patch)
tree058d5a4bf953622d89d2d91d2c9054200bbe8cc2 /gnu/packages/storage.scm
parentf85ca6eda044c43bd5b9b54e756c02fd90c372f1 (diff)
downloadguix-patches-63d4ef52ebad4157817d56ccbe974da8fff81929.tar
guix-patches-63d4ef52ebad4157817d56ccbe974da8fff81929.tar.gz
gnu: Remove GCC < 7 workarounds.
* gnu/packages/emulators.scm (dolphin-emu)[native-inputs]: Remove GCC-7. [arguments]: Adjust accordingly. * gnu/packages/games.scm (openrct2): Likewise. * gnu/packages/linux.scm (make-linux-libre): Likewise. * gnu/packages/mpd.scm (mpd): Likewise. * gnu/packages/storage.scm (ceph): Likewise.
Diffstat (limited to 'gnu/packages/storage.scm')
-rw-r--r--gnu/packages/storage.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 063825f429..4cff9665d5 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -237,11 +237,6 @@
(("^add_ceph_test\\(osd-copy-from\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-fast-mark-down\\.sh.*$") "\n"))
#t)))
- (add-before 'configure 'gcc-workaround
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
(add-before 'check 'set-check-environment
(lambda _
;; Run tests in parallel.
@@ -289,8 +284,7 @@
(outputs
'("out" "lib"))
(native-inputs
- `(("gcc" ,gcc-7) ;7 or later is required
- ("gperf" ,gperf)
+ `(("gperf" ,gperf)
("pkg-config" ,pkg-config)
("python-cython" ,python-cython)
("python-sphinx" ,python-sphinx)