summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emulators.scm6
-rw-r--r--gnu/packages/games.scm13
-rw-r--r--gnu/packages/linux.scm9
-rw-r--r--gnu/packages/mpd.scm17
-rw-r--r--gnu/packages/storage.scm8
5 files changed, 7 insertions, 46 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 184a3bc859..16dc7945ba 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -151,11 +151,6 @@
'(#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'fixgcc7
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
(add-before 'configure 'generate-fonts&hardcore-libvulkan-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((fontfile
@@ -189,7 +184,6 @@
"-DX11_FOUND=1")))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("gcc" ,gcc-7) ; Building with gcc@5 doesn't work anymore.
("gettext" ,gnu-gettext)))
(inputs
`(("alsa-lib" ,alsa-lib)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f46da6cff4..8858de7713 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2615,16 +2615,12 @@ Transport Tycoon Deluxe.")
"/share/openrct2/title-sequences") "data/title")
(copy-recursively (string-append objects
"/share/openrct2/objects") "data/object"))))
- (add-before 'configure 'fixgcc7
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
- (add-after 'fixgcc7 'get-rid-of-errors
+ (add-before 'configure 'get-rid-of-errors
(lambda _
;; Don't treat warnings as errors.
(substitute* "CMakeLists.txt"
- (("-Werror") "")))))))
+ (("-Werror") ""))
+ #t)))))
(inputs `(("curl" ,curl)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
@@ -2640,8 +2636,7 @@ Transport Tycoon Deluxe.")
("speexdsp" ,speexdsp)
("zlib" ,zlib)))
(native-inputs
- `(("gcc" ,gcc-7)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(home-page "https://github.com/OpenRCT2/OpenRCT2")
(synopsis "Free software re-implementation of RollerCoaster Tycoon 2")
(description "OpenRCT2 is a free software re-implementation of
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d7c242015e..e71c62900f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -308,10 +308,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
("flex" ,flex)
("bison" ,bison)
- ;; Build with GCC-7 for full retpoline support.
- ;; FIXME: Remove this when our default compiler has retpoline support.
- ("gcc" ,gcc-7)
-
;; These are needed to compile the GCC plugins.
("gmp" ,gmp)
("mpfr" ,mpfr)
@@ -338,11 +334,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(substitute* (find-files "." "^Makefile(\\.include)?$")
(("/bin/pwd") "pwd"))
#t))
- (add-before 'configure 'work-around-gcc-7-include-path-issue
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
(replace 'configure
(lambda* (#:key inputs native-inputs target #:allow-other-keys)
;; Avoid introducing timestamps
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 7885e21aa4..56ffe177f2 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -103,17 +103,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
"1ix52vfa8k8my4xyr8b0phg8605b2xchyzyva908m08vpzm14w94"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Ddocumentation=true") ; The default is 'false'...
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'expand-C++-include-path
- ;; Make <gcc>/include/c++/ext/string_conversions.h find <stdlib.h>.
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((path "CPLUS_INCLUDE_PATH")
- (gcc (assoc-ref inputs "gcc"))
- (c++ (string-append gcc "/include/c++")))
- (setenv path (string-append c++ ":" (getenv path)))
- #t))))))
+ `(#:configure-flags '("-Ddocumentation=true"))) ;the default is 'false'...
(inputs `(("ao" ,ao)
("alsa-lib" ,alsa-lib)
("avahi" ,avahi)
@@ -135,10 +125,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
("pulseaudio" ,pulseaudio)
("sqlite" ,sqlite)
("zlib" ,zlib)))
- ;; MPD > 0.21 requires > GCC 6
- (native-inputs `(("gcc" ,gcc-8)
- ("gcc-lib" ,gcc-8 "lib")
- ("pkg-config" ,pkg-config)
+ (native-inputs `(("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx)))
;; Missing optional inputs:
;; libyajl
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 063825f429..4cff9665d5 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -237,11 +237,6 @@
(("^add_ceph_test\\(osd-copy-from\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-fast-mark-down\\.sh.*$") "\n"))
#t)))
- (add-before 'configure 'gcc-workaround
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t))
(add-before 'check 'set-check-environment
(lambda _
;; Run tests in parallel.
@@ -289,8 +284,7 @@
(outputs
'("out" "lib"))
(native-inputs
- `(("gcc" ,gcc-7) ;7 or later is required
- ("gperf" ,gperf)
+ `(("gperf" ,gperf)
("pkg-config" ,pkg-config)
("python-cython" ,python-cython)
("python-sphinx" ,python-sphinx)