summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-12 14:29:07 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-12 14:34:22 +0100
commit8a8e8198ec4ebedd0400c8adcd85e15da3d43ca0 (patch)
tree4461e973ad41fc89fa5c3969422a2445098f4432 /gnu/packages/statistics.scm
parent28df54d77675a2247de17a8e45f57a0c613fb152 (diff)
downloadguix-patches-8a8e8198ec4ebedd0400c8adcd85e15da3d43ca0.tar
guix-patches-8a8e8198ec4ebedd0400c8adcd85e15da3d43ca0.tar.gz
gnu: Add r-puniform.
* gnu/packages/statistics.scm (r-puniform): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 3f3c4e3912..9761b9ceaf 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5990,3 +5990,71 @@ Methods are provided for a variety of fitted models, including @code{lm()} and
@code{robu()} (from @code{robumeta}), and @code{rma.uni()} and @code{rma.mv()}
(from @code{metafor}).")
(license license:gpl3)))
+
+(define-public r-puniform
+ (package
+ (name "r-puniform")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "puniform" version))
+ (sha256
+ (base32
+ "0v2977y9cwjx74xk0ig745g09wn7nrcsrg4f6v315sglsm18iaa8"))))
+ (properties `((upstream-name . "puniform")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-adgoftest" ,r-adgoftest)
+ ("r-metafor" ,r-metafor)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page
+ "https://github.com/RobbievanAert/puniform")
+ (synopsis
+ "Meta-Analysis Methods Correcting for Publication Bias")
+ (description
+ "This package provides meta-analysis methods that correct for publication
+bias and outcome reporting bias. Four methods and a visual tool are currently
+included in the package.
+
+@enumerate
+@item The p-uniform method as described in van Assen, van Aert, and Wicherts
+(2015) @url{doi:10.1037/met0000025} can be used for estimating the average
+effect size, testing the null hypothesis of no effect, and testing for
+publication bias using only the statistically significant effect sizes of
+primary studies.
+
+@item The p-uniform* method as described in van Aert and van Assen (2019)
+@url{doi:10.31222/osf.io/zqjr9}. This method is an extension of the p-uniform
+method that allows for estimation of the average effect size and the
+between-study variance in a meta-analysis, and uses both the statistically
+significant and nonsignificant effect sizes.
+
+@item The hybrid method as described in van Aert and van Assen (2017)
+@url{doi:10.3758/s13428-017-0967-6}. The hybrid method is a meta-analysis
+method for combining an original study and replication and while taking into
+account statistical significance of the original study. The p-uniform and
+hybrid method are based on the statistical theory that the distribution of
+p-values is uniform conditional on the population effect size.
+
+@item
+The fourth method in the package is the Snapshot Bayesian Hybrid Meta-Analysis
+Method as described in van Aert and van Assen (2018)
+@url{doi:10.1371/journal.pone.0175302}. This method computes posterior
+probabilities for four true effect sizes (no, small, medium, and large) based
+on an original study and replication while taking into account publication bias
+in the original study. The method can also be used for computing the required
+sample size of the replication akin to power analysis in null hypothesis
+significance testing.
+@end enumerate
+
+The meta-plot is a visual tool for meta-analysis that
+provides information on the primary studies in the meta-analysis, the results
+of the meta-analysis, and characteristics of the research on the effect under
+study (van Assen and others, 2020).
+
+Helper functions to apply the Correcting for Outcome Reporting Bias (CORB)
+method to correct for outcome reporting bias in a meta-analysis (van Aert &
+Wicherts, 2020).")
+ (license license:gpl2+)))