summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-12 14:26:13 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-12 14:34:20 +0100
commit28df54d77675a2247de17a8e45f57a0c613fb152 (patch)
treed662630b2ba2a08e74b15734608cf23c305808b6 /gnu/packages/statistics.scm
parent3a82f1fba2acdcaacd40d4730f3f84ccf0717392 (diff)
downloadguix-patches-28df54d77675a2247de17a8e45f57a0c613fb152.tar
guix-patches-28df54d77675a2247de17a8e45f57a0c613fb152.tar.gz
gnu: Add r-clubsandwich.
* gnu/packages/statistics.scm (r-clubsandwich): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 65a210a63b..3f3c4e3912 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5952,3 +5952,41 @@ popular stats packages like SAS, Stata and SPSS.")
"Contains functions useful for data screening, testing moderation,
mediation and estimating power.")
(license license:gpl2+)))
+
+(define-public r-clubsandwich
+ (package
+ (name "r-clubsandwich")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "clubSandwich" version))
+ (sha256
+ (base32
+ "0jazgka18bb5n58d5sn94q7rc9sac82qrpl2i5b4rkx9q2pb39cn"))))
+ (properties `((upstream-name . "clubSandwich")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-sandwich" ,r-sandwich)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/jepusto/clubSandwich")
+ (synopsis "Cluster-Robust (Sandwich) Variance Estimators with Small-Sample
+Corrections")
+ (description
+ "Provides several cluster-robust variance estimators (i.e.,
+sandwich estimators) for ordinary and weighted least squares linear regression
+models, including the bias-reduced linearization estimator introduced by Bell
+and McCaffrey (2002)
+@url{http://www.statcan.gc.ca/pub/12-001-x/2002002/article/9058-eng.pdf} and
+developed further by Pustejovsky and Tipton (2017)
+@url{doi:10.1080/07350015.2016.1247004}. The package includes functions for estimating
+the variance- covariance matrix and for testing single- and multiple-
+contrast hypotheses based on Wald test statistics. Tests of single regression
+coefficients use Satterthwaite or saddle-point corrections. Tests of multiple-
+contrast hypotheses use an approximation to Hotelling's T-squared distribution.
+Methods are provided for a variety of fitted models, including @code{lm()} and
+@code{mlm} objects, @code{glm()}, ivreg (from package @code{AER}), @code{plm()}
+(from package @code{plm}), @code{gls()} and @code{lme()} (from @code{nlme}),
+@code{robu()} (from @code{robumeta}), and @code{rma.uni()} and @code{rma.mv()}
+(from @code{metafor}).")
+ (license license:gpl3)))