summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-06-25 19:31:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-06-25 19:47:21 +0300
commit7754136e464e02284624ad05c196d9ec26099143 (patch)
tree37589ca27cff75508a28d433b7640902c95eaa9d /gnu/packages/ssh.scm
parent46475f72ab6127e7818fdea4a0ea9cc07c60a5f4 (diff)
downloadguix-patches-7754136e464e02284624ad05c196d9ec26099143.tar
guix-patches-7754136e464e02284624ad05c196d9ec26099143.tar.gz
gnu: openssh: Clean-up custom install phase.
* gnu/packages/ssh.scm (openssh)[arguments]: Factor out outputs in custom 'install phase to clean-up code.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 4bb0ad59f0..2fd02475d3 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -220,20 +220,17 @@ a server that supports the SSH-2 protocol.")
#t))
(replace 'install
(lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
- ;; install without host keys and system configuration files
- (apply invoke "make" "install-nosysconf" make-flags)
- (install-file "contrib/ssh-copy-id"
- (string-append (assoc-ref outputs "out")
- "/bin/"))
- (chmod (string-append (assoc-ref outputs "out")
- "/bin/ssh-copy-id") #o555)
- (install-file "contrib/ssh-copy-id.1"
- (string-append (assoc-ref outputs "out")
- "/share/man/man1/"))
- ;; Don't install the PRIVSEP_PATH directory.
- (delete-file-recursively
- (string-append (assoc-ref outputs "out") "/var"))
- #t)))))
+ (let ((out (assoc-ref outputs "out")))
+ ;; install without host keys and system configuration files
+ (apply invoke "make" "install-nosysconf" make-flags)
+ (install-file "contrib/ssh-copy-id"
+ (string-append out "/bin/"))
+ (chmod (string-append out "/bin/ssh-copy-id") #o555)
+ (install-file "contrib/ssh-copy-id.1"
+ (string-append out "/share/man/man1/"))
+ ;; Don't install the PRIVSEP_PATH directory.
+ (delete-file-recursively (string-append out "/var"))
+ #t))))))
(synopsis "Client and server for the secure shell (ssh) protocol")
(description
"The SSH2 protocol implemented in OpenSSH is standardised by the