summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-06-25 19:28:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-06-25 19:47:17 +0300
commit46475f72ab6127e7818fdea4a0ea9cc07c60a5f4 (patch)
treee5c5a68a3cc8921c2ff8556bd964db918c77f176 /gnu/packages/ssh.scm
parent8566d8793b005ae8ee2bf63b8817b301c94849cb (diff)
downloadguix-patches-46475f72ab6127e7818fdea4a0ea9cc07c60a5f4.tar
guix-patches-46475f72ab6127e7818fdea4a0ea9cc07c60a5f4.tar.gz
gnu: openssh: Don't create the PRIVSEP_PATH directory.
* gnu/packages/ssh.scm (openssh)[arguments]: Modify the custom 'install phase to remove the /var directory.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 010ed40707..4bb0ad59f0 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
@@ -230,6 +230,9 @@ a server that supports the SSH-2 protocol.")
(install-file "contrib/ssh-copy-id.1"
(string-append (assoc-ref outputs "out")
"/share/man/man1/"))
+ ;; Don't install the PRIVSEP_PATH directory.
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out") "/var"))
#t)))))
(synopsis "Client and server for the secure shell (ssh) protocol")
(description