summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-05 23:52:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-05 23:52:24 -0400
commit3e34f89980416a3b2f8637b3f7d15e35ff56e92d (patch)
tree44b9f27befff4ce289a3175daca170dfdb0d1d89 /gnu/packages/ssh.scm
parent0ec195ff02f2817bc52f9c06b85a89b414b0b28c (diff)
downloadguix-patches-3e34f89980416a3b2f8637b3f7d15e35ff56e92d.tar
guix-patches-3e34f89980416a3b2f8637b3f7d15e35ff56e92d.tar.gz
gnu: lsh: Enable some tests.
* gnu/packages/ssh.scm (lsh)[native-inputs]: Add autoconf and automake. [arguments]: Remove #:tests? argument. [phases]{disable-failing-tests}: New phase.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index e660c1cc5f..ca99235a01 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -598,7 +598,9 @@ basis for almost any application.")
(patches (search-patches "lsh-fix-x11-forwarding.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("m4" ,m4)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("m4" ,m4)
("guile" ,guile-2.0)
("gperf" ,gperf)
("psmisc" ,psmisc))) ; for `killall'
@@ -630,14 +632,20 @@ basis for almost any application.")
;; 'lsh_argp.h' checks HAVE_ARGP_PARSE but nothing
;; defines it.
"CPPFLAGS=-DHAVE_ARGP_PARSE")
-
- ;; FIXME: Tests won't run in a chroot, presumably because
- ;; /etc/profile is missing, and thus clients get an empty $PATH
- ;; and nothing works.
- #:tests? #f
-
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; FIXME: Most tests won't run in a chroot, presumably because
+ ;; /etc/profile is missing, and thus clients get an empty $PATH
+ ;; and nothing works. Run only the subset that passes.
+ (delete-file "configure") ;force rebootstrap
+ (substitute* "src/testsuite/Makefile.am"
+ (("seed-test \\\\") ;prevent trailing slash
+ "seed-test")
+ (("^\t(lsh|daemon|tcpip|socks|lshg|lcp|rapid7|lshd).*test.*")
+ ""))
+ #t))
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
(let* ((nettle (assoc-ref inputs "nettle"))