summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-05 23:48:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-05 23:48:45 -0400
commit0ec195ff02f2817bc52f9c06b85a89b414b0b28c (patch)
treea0badd05075d0475ff7c3c4658ab13b212211f45 /gnu/packages/ssh.scm
parentfb81bd9e0bcd12bd371ec8b87f5ade777995e6c4 (diff)
downloadguix-patches-0ec195ff02f2817bc52f9c06b85a89b414b0b28c.tar
guix-patches-0ec195ff02f2817bc52f9c06b85a89b414b0b28c.tar.gz
gnu: lsh: Fix X11 forwarding.
Fixes <https://issues.guix.gnu.org/24049>. * gnu/packages/patches/lsh-fix-x11-forwarding.patch: Add patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/ssh.scm (lsh)[source]: Apply it. [inputs]: Add libxau. Reported-by: myglc2 <myglc2@gmail.com>
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index d28e3ef83c..e660c1cc5f 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -594,7 +594,8 @@ basis for almost any application.")
(substitute* "src/testsuite/login-auth-test"
(("/bin/cat") "cat"))
- #t))))
+ #t))
+ (patches (search-patches "lsh-fix-x11-forwarding.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("m4" ,m4)
@@ -615,7 +616,8 @@ basis for almost any application.")
;; The server (lshd) invokes xauth when X11 forwarding is requested.
;; This adds 24 MiB (or 27%) to the closure of lsh.
- ("xauth" ,xauth)))
+ ("xauth" ,xauth)
+ ("libxau" ,libxau))) ;also required for x11-forwarding
(arguments
'(;; Skip the `configure' test that checks whether /dev/ptmx &
;; co. work as expected, because it relies on impurities (for