summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorHugo Lecomte <hugo.lecomte@inria.fr>2021-07-05 09:29:29 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-09 11:58:51 +0200
commit885c1bd06ec8212f3882bf81ff0900a7fadda735 (patch)
treeffd348c730722e1fc0c1d6dcbb9452c853b91e90 /gnu/packages/sphinx.scm
parentd6b3908840f6916b4b697bff8b49cd9018d0dbc1 (diff)
downloadguix-patches-885c1bd06ec8212f3882bf81ff0900a7fadda735.tar
guix-patches-885c1bd06ec8212f3882bf81ff0900a7fadda735.tar.gz
gnu: Add python-sphinxcontrib-autoprogram.
* gnu/packages/sphinx.scm (python-sphinxcontrib-autoprogram): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 19015092c7..8928b795f4 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -812,3 +812,28 @@ Jupyter kernel, and embeds outputs of that code in the document. It has
support for rich output such as images, LaTeX math and even JavaScript
widgets, and supports thebelab for live code execution with minimal effort.")
(license license:bsd-3)))
+
+(define-public python-sphinxcontrib-autoprogram
+ (package
+ (name "python-sphinxcontrib-autoprogram")
+ (version "0.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxcontrib-autoprogram" version))
+ (sha256
+ (base32
+ "06hzim0d3fd72kf30fyjbbm5n8ibyybic0kf62gm79qp50zjwr5w"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (native-inputs
+ `(("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/sphinx-contrib/autoprogram")
+ (synopsis "Documenting CLI programs")
+ (description
+ "This Sphinx extension, @code{sphinxcontrib.autoprogram}, provides an
+automated way to document command-line programs. It scans
+@code{argparse.ArgumentParser} object, and then expands it into a set of
+@code{.. program::} and @code{.. option::} directives.")
+ (license license:bsd-2)))