summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorHugo Lecomte <hugo.lecomte@inria.fr>2021-07-05 09:29:28 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-09 11:58:51 +0200
commitd6b3908840f6916b4b697bff8b49cd9018d0dbc1 (patch)
treedba98438df070fc7f88881cbc4916d95bafbd4d1 /gnu/packages/sphinx.scm
parente31979c3a50a781d8d0341659666e865dd1d1403 (diff)
downloadguix-patches-d6b3908840f6916b4b697bff8b49cd9018d0dbc1.tar
guix-patches-d6b3908840f6916b4b697bff8b49cd9018d0dbc1.tar.gz
gnu: Add python-jupyter-sphinx.
* gnu/packages/sphinx.scm (python-jupyter-sphinx): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 428a701d87..19015092c7 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -783,3 +784,31 @@ executed during the Sphinx build process.")
(synopsis "Sphinx cross-reference tool")
(description "Sphinx objects.inv inspection/manipulation tool.")
(license license:expat)))
+
+(define-public python-jupyter-sphinx
+ (package
+ (name "python-jupyter-sphinx")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_sphinx" version))
+ (sha256
+ (base32
+ "1wma60787m2451nn4bc4jw7bzqksplplb84wqxm34iaw70499z1p"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-ipython" ,python-ipython)
+ ("python-ipywidgets" ,python-ipywidgets)
+ ("python-nbconvert" ,python-nbconvert)
+ ("python-nbformat" ,python-nbformat)))
+ (native-inputs
+ `(("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/jupyter/jupyter-sphinx/")
+ (synopsis "Jupyter Sphinx Extensions")
+ (description
+ "Jupyter-sphinx is a Sphinx extension that executes embedded code in a
+Jupyter kernel, and embeds outputs of that code in the document. It has
+support for rich output such as images, LaTeX math and even JavaScript
+widgets, and supports thebelab for live code execution with minimal effort.")
+ (license license:bsd-3)))