summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-12 23:33:08 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-24 21:54:31 +0200
commit67be8943c387f95e40ae4b746497524cfc26012d (patch)
tree6173624a8966f7e3cc996a98a8f859ae22d3dfa1 /gnu/packages/sphinx.scm
parent62ad0c8b0f4e67d28e78563a5f5694ffac6c20a2 (diff)
downloadguix-patches-67be8943c387f95e40ae4b746497524cfc26012d.tar
guix-patches-67be8943c387f95e40ae4b746497524cfc26012d.tar.gz
gnu: Add python-sphinxcontrib-jsmath.
* gnu/packages/sphinx.scm (python-sphinxcontrib-jsmath): New public variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index a32336920c..71cff12a2c 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -148,6 +148,26 @@ Apple help books.")
@url{Devhelp,https://wiki.gnome.org/Apps/Devhelp} documents.")
(license license:bsd-2)))
+(define-public python-sphinxcontrib-jsmath
+ (package
+ (name "python-sphinxcontrib-jsmath")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxcontrib-jsmath" version))
+ (sha256
+ (base32
+ "1f64w19j33sp151jimibraw6qrbhd5gxy8hs3797w9478m55x4m9"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;XXX: circular dependency on Sphinx
+ (home-page "https://github.com/sphinx-doc/sphinxcontrib-jsmath")
+ (synopsis "Sphinx extension to render math equations")
+ (description
+ "@code{sphinxcontrib-jsmath} is a Sphinx extension which renders display
+math in HTML via JavaScript.")
+ (license license:bsd-3)))
+
(define-public python-sphinxcontrib-newsfeed
(package
(name "python-sphinxcontrib-newsfeed")