summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-12 23:32:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-24 21:54:31 +0200
commit62ad0c8b0f4e67d28e78563a5f5694ffac6c20a2 (patch)
tree2c799cc74232de61ecb7289d56ab7f16f62054e3 /gnu/packages/sphinx.scm
parentbc2a3f7c62ca6e7b032c977eeda295a152350eef (diff)
downloadguix-patches-62ad0c8b0f4e67d28e78563a5f5694ffac6c20a2.tar
guix-patches-62ad0c8b0f4e67d28e78563a5f5694ffac6c20a2.tar.gz
gnu: Add python-sphinxcontrib-devhelp.
* gnu/packages/sphinx.scm (python-sphinxcontrib-devhelp): New public variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 47ddf668d5..a32336920c 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -128,6 +128,26 @@ sources.")
Apple help books.")
(license license:bsd-2)))
+(define-public python-sphinxcontrib-devhelp
+ (package
+ (name "python-sphinxcontrib-devhelp")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxcontrib-devhelp" version))
+ (sha256
+ (base32
+ "0d2a57kqxl72i55rns0ly1i044y2x234b9sdi89ajc3kjdvv0r3c"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;XXX: circular dependency on Sphinx
+ (home-page "https://github.com/sphinx-doc/sphinxcontrib-devhelp")
+ (synopsis "Sphinx extension for creating Devhelp documents")
+ (description
+ "@code{sphinxcontrib-devhelp} is a Sphinx extension which outputs
+@url{Devhelp,https://wiki.gnome.org/Apps/Devhelp} documents.")
+ (license license:bsd-2)))
+
(define-public python-sphinxcontrib-newsfeed
(package
(name "python-sphinxcontrib-newsfeed")