summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-12 23:31:03 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-24 21:54:31 +0200
commitbc2a3f7c62ca6e7b032c977eeda295a152350eef (patch)
treed1803c93f36eff5c4ee4586478a018d64521983c /gnu/packages/sphinx.scm
parentc5c55a9f2c607eca1f7649026b591284c116b141 (diff)
downloadguix-patches-bc2a3f7c62ca6e7b032c977eeda295a152350eef.tar
guix-patches-bc2a3f7c62ca6e7b032c977eeda295a152350eef.tar.gz
gnu: Add python-sphinxcontrib-applehelp.
* gnu/packages/sphinx.scm (python-sphinxcontrib-applehelp): New public variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 9af080663f..47ddf668d5 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -108,6 +108,26 @@ sources.")
("python2-typing" ,python2-typing)
,@(package-propagated-inputs base))))))
+(define-public python-sphinxcontrib-applehelp
+ (package
+ (name "python-sphinxcontrib-applehelp")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxcontrib-applehelp" version))
+ (sha256
+ (base32
+ "15rqmgphj4wqf4m5wnzxgmwxx5jwfzb0j0nb94ql0x5wnar0mapd"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;XXX: circular dependency on Sphinx
+ (home-page "https://github.com/sphinx-doc/sphinxcontrib-applehelp")
+ (synopsis "Sphinx extension for creating Apple help books")
+ (description
+ "@code{sphinxcontrib-applehelp} is a Sphinx extension which outputs
+Apple help books.")
+ (license license:bsd-2)))
+
(define-public python-sphinxcontrib-newsfeed
(package
(name "python-sphinxcontrib-newsfeed")