summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2018-11-12 16:00:38 +0000
committerLudovic Courtès <ludo@gnu.org>2018-11-14 21:34:08 +0100
commit0fc499834f7357a8bb76cca06b8979c67961b316 (patch)
treed99279bfcfd7634c42554a38ee292b4e505c8e79 /gnu/packages/simulation.scm
parent3941cf5afa8cca3852651defb8e55dec89dee19c (diff)
downloadguix-patches-0fc499834f7357a8bb76cca06b8979c67961b316.tar
guix-patches-0fc499834f7357a8bb76cca06b8979c67961b316.tar.gz
gnu: Add python-fenics-fiat.
* gnu/packages/simulation.scm (python-fenics-fiat): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 7165fb55fb..ecdb2b2020 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -307,3 +307,45 @@ forms in a notation close to mathematical notation.
UFL is part of the FEniCS Project.")
(license license:lgpl3+)))
+
+(define-public python-fenics-fiat
+ (package
+ (name "python-fenics-fiat")
+ (version "2018.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fenics-fiat" version))
+ (sha256
+ (base32
+ "0fmjd93r6bwf6xs8csw86qzphrnr66xwv7f372w59gmq8mg6rljc"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-sympy" ,python-sympy)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) ":" (getenv "PYTHONPATH")))
+ (with-directory-excursion "test"
+ (invoke "py.test" "unit/"))
+ #t)))))
+ (home-page "https://bitbucket.org/fenics-project/fiat/")
+ (synopsis "Tabulation of finite element function spaces")
+ (description
+ "The FInite element Automatic Tabulator (FIAT) supports
+generation of arbitrary order instances of the Lagrange elements on
+lines, triangles, and tetrahedra. It is also capable of generating
+arbitrary order instances of Jacobi-type quadrature rules on the same
+element shapes. Further, H(div) and H(curl) conforming finite element
+spaces such as the families of Raviart-Thomas, Brezzi-Douglas-Marini
+and Nedelec are supported on triangles and tetrahedra. Upcoming
+versions will also support Hermite and nonconforming elements.
+
+FIAT is part of the FEniCS Project.")
+ (license license:lgpl3+)))