summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2018-11-12 16:00:37 +0000
committerLudovic Courtès <ludo@gnu.org>2018-11-14 21:34:08 +0100
commit3941cf5afa8cca3852651defb8e55dec89dee19c (patch)
treece56673503153a3d623dce0f3c9500904911dadb /gnu/packages/simulation.scm
parentf7a4757a4cabfe70f07216ab3f7eac60a80b82ad (diff)
downloadguix-patches-3941cf5afa8cca3852651defb8e55dec89dee19c.tar
guix-patches-3941cf5afa8cca3852651defb8e55dec89dee19c.tar.gz
gnu: Add python-fenics-ufl.
* gnu/packages/simulation.scm (python-fenics-ufl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 86b1aba695..7165fb55fb 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -270,3 +270,40 @@ a class implementing a predefined C++ interface, there is no limit to
the complexity of that interface. Parallel support depends on the
@code{mpi4py} interface.")
(license license:lgpl3+)))
+
+(define-public python-fenics-ufl
+ (package
+ (name "python-fenics-ufl")
+ (version "2018.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fenics-ufl" version))
+ (sha256
+ (base32
+ "1fq8yc86s1s3c8c0b1rc2vf265q0hrkzg57100fg1nghcz0p4vla"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-numpy" ,python-numpy)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) ":" (getenv "PYTHONPATH")))
+ (with-directory-excursion "test"
+ (invoke "py.test"))
+ #t)))))
+ (home-page "https://bitbucket.org/fenics-project/ufl/")
+ (synopsis "Unified language for form-compilers")
+ (description "The Unified Form Language (UFL) is a domain specific
+language for declaration of finite element discretizations of
+variational forms. More precisely, it defines a flexible interface
+for choosing finite element spaces and defining expressions for weak
+forms in a notation close to mathematical notation.
+
+UFL is part of the FEniCS Project.")
+ (license license:lgpl3+)))