summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2020-02-09 16:10:28 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-02-09 21:00:11 +0100
commit2846aec2f7d53b9244ad55c1436437843287426a (patch)
tree4b730b380b31e19ef6f959ad0afc0c7c067da19c /gnu/packages/scheme.scm
parent13c6f9c9885092fe693ad29b0fe1e807de11a548 (diff)
downloadguix-patches-2846aec2f7d53b9244ad55c1436437843287426a.tar
guix-patches-2846aec2f7d53b9244ad55c1436437843287426a.tar.gz
gnu: chicken: Move to a separate module.
* gnu/packages/scheme.scm (chicken): Move to chicken.scm. * gnu/packages/chicken.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 1009896a70..c891a77a18 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -368,47 +368,6 @@ applications in many fields such as multimedia (web galleries, music players,
mashups, office (web agendas, mail clients, ...), etc.")
(license gpl2+)))
-(define-public chicken
- (package
- (name "chicken")
- (version "5.0.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://code.call-cc.org/releases/"
- version "/chicken-" version ".tar.gz"))
- (sha256
- (base32
- "15b5yrzfa8aimzba79x7v6y282f898rxqxfxrr446sjx9jwlpfd8"))))
- (build-system gnu-build-system)
- (arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (srfi srfi-1))
-
- ;; No `configure' script; run "make check" after "make install" as
- ;; prescribed by README.
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'check)
- (add-after 'install 'check
- (assoc-ref %standard-phases 'check)))
-
- #:make-flags (let ((out (assoc-ref %outputs "out")))
- (list "PLATFORM=linux"
- (string-append "PREFIX=" out)
- (string-append "VARDIR=" out "/var/lib")))
-
- ;; Parallel builds are not supported, as noted in README.
- #:parallel-build? #f))
- (home-page "http://www.call-cc.org/")
- (synopsis "R5RS Scheme implementation that compiles native code via C")
- (description
- "CHICKEN is a compiler for the Scheme programming language. CHICKEN
-produces portable and efficient C, supports almost all of the R5RS Scheme
-language standard, and includes many enhancements and extensions.")
- (license bsd-3)))
-
(define-public scheme48
(package
(name "scheme48")