summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/chicken.scm66
-rw-r--r--gnu/packages/scheme.scm41
3 files changed, 67 insertions, 41 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 64ad653542..d86b39cacb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -109,6 +109,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/check.scm \
%D%/packages/chemistry.scm \
%D%/packages/chez.scm \
+ %D%/packages/chicken.scm \
%D%/packages/chromium.scm \
%D%/packages/ci.scm \
%D%/packages/cinnamon.scm \
diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
new file mode 100644
index 0000000000..53631f9bd6
--- /dev/null
+++ b/gnu/packages/chicken.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages chicken)
+ #:use-module (gnu packages)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module ((guix licenses)
+ #:select (bsd-3)))
+
+(define-public chicken
+ (package
+ (name "chicken")
+ (version "5.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://code.call-cc.org/releases/"
+ version "/chicken-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15b5yrzfa8aimzba79x7v6y282f898rxqxfxrr446sjx9jwlpfd8"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (srfi srfi-1))
+
+ ;; No `configure' script; run "make check" after "make install" as
+ ;; prescribed by README.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check)))
+
+ #:make-flags (let ((out (assoc-ref %outputs "out")))
+ (list "PLATFORM=linux"
+ (string-append "PREFIX=" out)
+ (string-append "VARDIR=" out "/var/lib")))
+
+ ;; Parallel builds are not supported, as noted in README.
+ #:parallel-build? #f))
+ (home-page "http://www.call-cc.org/")
+ (synopsis "R5RS Scheme implementation that compiles native code via C")
+ (description
+ "CHICKEN is a compiler for the Scheme programming language. CHICKEN
+produces portable and efficient C, supports almost all of the R5RS Scheme
+language standard, and includes many enhancements and extensions.")
+ (license bsd-3)))
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 1009896a70..c891a77a18 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -368,47 +368,6 @@ applications in many fields such as multimedia (web galleries, music players,
mashups, office (web agendas, mail clients, ...), etc.")
(license gpl2+)))
-(define-public chicken
- (package
- (name "chicken")
- (version "5.0.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://code.call-cc.org/releases/"
- version "/chicken-" version ".tar.gz"))
- (sha256
- (base32
- "15b5yrzfa8aimzba79x7v6y282f898rxqxfxrr446sjx9jwlpfd8"))))
- (build-system gnu-build-system)
- (arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (srfi srfi-1))
-
- ;; No `configure' script; run "make check" after "make install" as
- ;; prescribed by README.
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'check)
- (add-after 'install 'check
- (assoc-ref %standard-phases 'check)))
-
- #:make-flags (let ((out (assoc-ref %outputs "out")))
- (list "PLATFORM=linux"
- (string-append "PREFIX=" out)
- (string-append "VARDIR=" out "/var/lib")))
-
- ;; Parallel builds are not supported, as noted in README.
- #:parallel-build? #f))
- (home-page "http://www.call-cc.org/")
- (synopsis "R5RS Scheme implementation that compiles native code via C")
- (description
- "CHICKEN is a compiler for the Scheme programming language. CHICKEN
-produces portable and efficient C, supports almost all of the R5RS Scheme
-language standard, and includes many enhancements and extensions.")
- (license bsd-3)))
-
(define-public scheme48
(package
(name "scheme48")