summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-02 22:03:18 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-03 00:11:06 -0500
commit25e811583fc1e718668147e50a0bf297b30e8017 (patch)
tree574eae578116ee49f4c0fa48b3896f8f218d72df /gnu/packages/samba.scm
parent3185c29ac1faf7e71baaff55d6d99704740b93a1 (diff)
downloadguix-patches-25e811583fc1e718668147e50a0bf297b30e8017.tar
guix-patches-25e811583fc1e718668147e50a0bf297b30e8017.tar.gz
gnu: samba: Prepare for tests.
* gnu/packages/samba.scm (samba)[arguments]: Update comment regarding the test suite failure. [make-flags]: Run the test suite with the '--quick' option, as it is very slow otherwise. [phases]{configure}: Add the '--enable-selftest' argument. [inputs]: Add libtirpc.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 8f723d5262..a6610bbf91 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -197,7 +197,8 @@ external dependencies.")
#t))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:make-flags '("TEST_OPTIONS=--quick") ;some tests are very long
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'setup-docbook-stylesheets
(lambda* (#:key inputs #:allow-other-keys)
@@ -219,6 +220,7 @@ external dependencies.")
(let* ((out (assoc-ref outputs "out"))
(libdir (string-append out "/lib")))
(invoke "./configure"
+ "--enable-selftest"
"--enable-fhs"
(string-append "--prefix=" out)
"--sysconfdir=/etc"
@@ -232,9 +234,8 @@ external dependencies.")
(substitute* "dynconfig/wscript"
(("bld\\.INSTALL_DIR.*") ""))
#t)))
- ;; XXX: The test infrastructure attempts to set password with
- ;; smbpasswd, which fails with "smbpasswd -L can only be used by root."
- ;; So disable tests until there's a workaround.
+ ;; FIXME: The test suite seemingly hangs after failing to provision the
+ ;; test environment.
#:tests? #f))
(inputs
`(("acl" ,acl)
@@ -247,6 +248,7 @@ external dependencies.")
("heimdal" ,heimdal)
("jansson" ,jansson)
("libarchive" ,libarchive)
+ ("libtirpc" ,libtirpc)
("linux-pam" ,linux-pam)
("lmdb" ,lmdb)
("openldap" ,openldap)