summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-02 17:03:57 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-03 00:11:06 -0500
commit3185c29ac1faf7e71baaff55d6d99704740b93a1 (patch)
tree7740ac7aff415c3729b121687b9705036bf4d438 /gnu/packages/samba.scm
parentdb29ee0b1b3fafc51a18247a118a10149e8cdb4f (diff)
downloadguix-patches-3185c29ac1faf7e71baaff55d6d99704740b93a1.tar
guix-patches-3185c29ac1faf7e71baaff55d6d99704740b93a1.tar.gz
gnu: samba: Unbundle cmocka, heimdal; add gamin.
* gnu/packages/samba.scm (samba)[snippet]: Update comment. [phases]{configure}: Remove '--bundled-libraries=com_err' argument. [inputs]: Add cmocka, heimdal, gamin. Remove TODO comment.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 9f1945db0b..8f723d5262 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -45,6 +45,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages docbook)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages linux)
@@ -189,7 +190,9 @@ external dependencies.")
(modules '((guix build utils)))
(snippet
'(begin
- ;; TODO: also remove the bundled ‘third_party/popt’.
+ ;; XXX: Some bundled libraries (e.g, popt, cmocka) are used from
+ ;; the system, but their bundled sources must be kept as they
+ ;; include the WAF scripts used for detecting them.
(delete-file-recursively "third_party/pyiso8601")
#t))))
(build-system gnu-build-system)
@@ -211,14 +214,12 @@ external dependencies.")
(string-append all " $XML_CATALOG_FILES")))
#t))
(replace 'configure
- ;; samba uses a custom configuration script that runs waf.
+ ;; Samba uses a custom configuration script that runs WAF.
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(libdir (string-append out "/lib")))
(invoke "./configure"
"--enable-fhs"
- ;; XXX: heimdal not packaged.
- "--bundled-libraries=com_err"
(string-append "--prefix=" out)
"--sysconfdir=/etc"
"--localstatedir=/var"
@@ -235,13 +236,15 @@ external dependencies.")
;; smbpasswd, which fails with "smbpasswd -L can only be used by root."
;; So disable tests until there's a workaround.
#:tests? #f))
- (inputs ; TODO: Add missing dependencies
+ (inputs
`(("acl" ,acl)
+ ("cmocka" ,cmocka)
("cups" ,cups)
- ;; ("gamin" ,gamin)
+ ("gamin" ,gamin)
("dbus", dbus)
("gpgme" ,gpgme)
("gnutls" ,gnutls)
+ ("heimdal" ,heimdal)
("jansson" ,jansson)
("libarchive" ,libarchive)
("linux-pam" ,linux-pam)