summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-19 15:33:01 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-19 18:56:55 +0200
commit3923e9d9421f2608c900d7815896e5809b154fec (patch)
tree87a0b470dc11b92d42aadf12a025f6d5427b86fa /gnu/packages/sagemath.scm
parent538230c9331b64844f1f2bdb884ae9a88d3ac537 (diff)
downloadguix-patches-3923e9d9421f2608c900d7815896e5809b154fec.tar
guix-patches-3923e9d9421f2608c900d7815896e5809b154fec.tar.gz
gnu: Add pynac.
* gnu/packages/sagemath.scm (pynac): New variable.
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 82b73d7811..07c13582de 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages compression)
#:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz))
@@ -231,3 +232,37 @@ represented as strings.")
"1wfivlwp30mzdy1697w7rzb8caajim50mc8h27k82yipn2qc5n4i"))))
(inputs
`(("fflas-ffpack" ,fflas-ffpack-2.3.2)))))
+
+(define-public pynac
+ (package
+ (name "pynac")
+ (version "0.7.25")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pynac/pynac/")
+ (commit (string-append "pynac-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nnifvg6kzx0lq6gz7znind8g30v3d2pjfwgsdiks3vv9kv9nbj3"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("flint" ,flint)
+ ("gmp" ,gmp)
+ ("python" ,python)
+ ("singular" ,singular)))
+ (synopsis "Sage fork of GiNaC")
+ (description "Pynac is a derivative of the C++ library GiNaC, which
+allows manipulation of symbolic expressions. It currently provides the
+backend for symbolic expressions in Sage. The main difference between
+Pynac and GiNaC is that Pynac relies on Sage to provide the operations
+on numerical types, while GiNaC depends on CLN for this purpose.")
+ (license license:gpl2+)
+ (home-page "http://pynac.org/")))