summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-19 09:55:42 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-19 18:56:55 +0200
commit538230c9331b64844f1f2bdb884ae9a88d3ac537 (patch)
tree90418422d28931f543da0642f610f3ba24c9a6ff /gnu/packages/sagemath.scm
parentf58b10cb3067bc9c9681f214142ecd3e9f16709b (diff)
downloadguix-patches-538230c9331b64844f1f2bdb884ae9a88d3ac537.tar
guix-patches-538230c9331b64844f1f2bdb884ae9a88d3ac537.tar.gz
gnu: python-gmpy2: Update to 2.1.0b1.
The gmpy2 package has become a standard package in sage-8.7, and the latest stable release is too old. * gnu/packages/sagemath.scm (python-gmpy2): Update to 2.1.0b1.
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 732011bf36..82b73d7811 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -65,18 +65,21 @@ but it can be used independently.")
(package-with-python2 python-cypari2))
;; The stable version of the following package is not young enough to be
-;; used with Sage, since it does not support cython. One would need to
-;; use an alpha release. On the other hand, Sage can be built without it.
+;; used with Sage, since it does not support cython; so we use a beta
+;; release.
(define-public python-gmpy2
(package
(name "python-gmpy2")
- (version "2.0.8")
+ (version "2.1.0b1")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "gmpy2" version ".zip"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aleaxit/gmpy")
+ (commit (string-append "gmpy2-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0grx6zmi99iaslm07w6c2aqpnmbkgrxcqjrqpfq223xri0r3w8yx"))))
+ "0ljvnmhxqdfsp0yy4c2hynhk5sggm63kkqsq4iwq4k9vsnx2xm97"))))
(build-system python-build-system)
(native-inputs
`(("unzip" ,unzip)))