summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorTomás Ortín Fernández <tomasortin@mailbox.org>2020-12-28 01:36:46 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2021-02-25 23:38:35 +0100
commit2e932dc352aa090120f70c54480d68ffa70ea784 (patch)
tree0cf12fb099d040e58eb3a561c83fc1351c607786 /gnu/packages/ruby.scm
parent42daea6503281dd29e093ba1f7185e6ae9d9a1b0 (diff)
downloadguix-patches-2e932dc352aa090120f70c54480d68ffa70ea784.tar
guix-patches-2e932dc352aa090120f70c54480d68ffa70ea784.tar.gz
gnu: Add ruby-benchmark.
* gnu/packages/ruby.scm (ruby-benchmark): New variable. Signed-off-by: Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c3a15abe4d..f2171c3c08 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12262,3 +12262,21 @@ options.")
exceptions with predefined messages.")
(home-page "https://github.com/ruby/e2mmap")
(license license:bsd-2)))
+
+(define-public ruby-benchmark
+ (package
+ (name "ruby-benchmark")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "benchmark" version))
+ (sha256
+ (base32
+ "1jvrl7400fv7v2jjri1r7ilj3sri36hzipwwgpn5psib4c9c59c6"))))
+ (build-system ruby-build-system)
+ (synopsis "Performance benchmarking library")
+ (description "This package provides methods for benchmarking Ruby code,
+giving detailed reports on the time taken for each task.")
+ (home-page "https://github.com/ruby/benchmark")
+ (license license:bsd-2)))