summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorTomás Ortín Fernández <tomasortin@mailbox.org>2020-12-28 01:27:53 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2021-02-25 23:38:18 +0100
commit42daea6503281dd29e093ba1f7185e6ae9d9a1b0 (patch)
tree83e2d9d55cb709d6fabb4359b6fe5ec1e3d112b1 /gnu/packages/ruby.scm
parent10b909a0249fd53d589890b357232db4165690f5 (diff)
downloadguix-patches-42daea6503281dd29e093ba1f7185e6ae9d9a1b0.tar
guix-patches-42daea6503281dd29e093ba1f7185e6ae9d9a1b0.tar.gz
gnu: Add ruby-e2mmap.
* gnu/packages/ruby.scm (ruby-e2mmap): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4c9829612f..c3a15abe4d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2020 Holgr Peters <holger.peters@posteo.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 EuAndreh <eu@euandre.org>
+;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -12239,3 +12240,25 @@ multiple adapters, various log level combinations and message formatting
options.")
(home-page "https://github.com/rudionrails/yell")
(license license:expat)))
+
+(define-public ruby-e2mmap
+ (package
+ (name "ruby-e2mmap")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "e2mmap" version))
+ (sha256
+ (base32
+ "0n8gxjb63dck3vrmsdcqqll7xs7f3wk78mw8w0gdk9wp5nx6pvj5"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ;; There is a rakefile but no tests
+ (synopsis
+ "Module for defining custom exceptions with specific messages")
+ (description
+ "Exception2MessageMapper (e2mmap) is a helper module for easily defining
+exceptions with predefined messages.")
+ (home-page "https://github.com/ruby/e2mmap")
+ (license license:bsd-2)))