summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-14 20:52:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-15 17:19:27 +0200
commit1007640a63de6749a93e94a2751f66af56b01d07 (patch)
tree2bb80ee12174e58cfffa7398d74fc9bc7e73dbae /gnu/packages/ruby.scm
parent8fcba3be282b4df60eec99338e5afee061d87242 (diff)
downloadguix-patches-1007640a63de6749a93e94a2751f66af56b01d07.tar
guix-patches-1007640a63de6749a93e94a2751f66af56b01d07.tar.gz
gnu: ruby-concurrent: Update to 1.1.5.
* gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch, gnu/packages/patches/ruby-concurrent-test-arm.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/ruby.scm (ruby-concurrent): Update to 1.1.5. [source](patches): Remove. [arguments]: Set #:test-target to "ci". Remove obsolete phases. Remove dependencies on 'rake_compiler_dock' and concurrent_ruby.jar.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm42
1 files changed, 27 insertions, 15 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index bb8a9d535b..d5f7fa59c6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 ng0 <ng0@n0.is>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
@@ -7170,7 +7170,7 @@ call.")
(define-public ruby-concurrent
(package
(name "ruby-concurrent")
- (version "1.0.5")
+ (version "1.1.5")
(source
(origin
(method git-fetch)
@@ -7182,14 +7182,10 @@ call.")
(file-name (git-file-name name version))
(sha256
(base32
- "1618ald6mhz86hapgw9hs3cvb518k48fk6fxficdrdg3zcx8n302"))
- ;; Exclude failing test reported at
- ;; https://github.com/ruby-concurrency/concurrent-ruby/issues/534
- (patches (search-patches "ruby-concurrent-ignore-broken-test.patch"
- "ruby-concurrent-test-arm.patch"))))
+ "193q2k47vk7qdvv9hlhmmdxgy91xl4imapyk1ijdg9vgf46knyzj"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"
+ `(#:test-target "ci"
#:phases
(modify-phases %standard-phases
(add-before 'replace-git-ls-files 'remove-extra-gemspecs
@@ -7199,15 +7195,31 @@ call.")
(delete-file "concurrent-ruby-edge.gemspec")
(delete-file "concurrent-ruby-ext.gemspec")
#t))
- (add-before 'build 'replace-git-ls-files2
+ (replace 'replace-git-ls-files
+ (lambda _
+ ;; XXX: The default substitution made by this phase is not fully
+ ;; compatible with "git ls-files". The latter produces file names
+ ;; such as "lib/foo", whereas ruby-build-system uses "find . [...]"
+ ;; which gives "./lib/foo". That difference in turn breaks the
+ ;; comparison against a glob pattern in this script.
+ (substitute* "concurrent-ruby.gemspec"
+ (("git ls-files") "find * -type f | sort"))
+ #t))
+ (add-before 'build 'remove-jar-from-gemspec
(lambda _
- (substitute* "support/file_map.rb"
- (("git ls-files") "find * |sort"))
+ ;; The gemspec wants to include a JAR file that we do not build
+ ;; nor need.
+ (substitute* "concurrent-ruby.gemspec"
+ (("'lib/concurrent/concurrent_ruby.jar'")
+ ""))
+ #t))
+ (add-before 'build 'remove-rake_compiler_dock-dependency
+ (lambda _
+ ;; This library is only used when building for non-MRI targets.
+ (substitute* "Rakefile"
+ (("require 'rake_compiler_dock'")
+ ""))
#t))
- (add-before 'check 'rake-compile
- ;; Fix the test error described at
- ;; https://github.com/ruby-concurrency/concurrent-ruby/pull/408
- (lambda _ (invoke "rake" "compile")))
(add-before 'check 'remove-timecop-dependency
;; Remove timecop-dependent tests as having timecop as a depedency
;; causes circular depedencies.