summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-14 20:50:47 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-15 17:19:27 +0200
commit8fcba3be282b4df60eec99338e5afee061d87242 (patch)
tree5ac711d75e68543cafb0311b7df47843b18c4384 /gnu/packages/ruby.scm
parent7d87eede5d7b309d27556fc1614ceba98be2f577 (diff)
downloadguix-patches-8fcba3be282b4df60eec99338e5afee061d87242.tar
guix-patches-8fcba3be282b4df60eec99338e5afee061d87242.tar.gz
gnu: ruby-concurrent: Do not use unstable source tarball.
* gnu/packages/ruby.scm (ruby-concurrent)[source]: Switch to GIT-FETCH.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7d736c7c27..bb8a9d535b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7173,17 +7173,16 @@ call.")
(version "1.0.5")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
;; Download from GitHub because the rubygems version does not contain
;; Rakefile.
- (uri (string-append
- "https://github.com/ruby-concurrency/concurrent-ruby/archive/v"
- version
- ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/ruby-concurrency/concurrent-ruby")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0qhv0qzsby4iijgwa4s9r88zj8123pmyz1dwaqzdk57xgqll9pny"))
+ "1618ald6mhz86hapgw9hs3cvb518k48fk6fxficdrdg3zcx8n302"))
;; Exclude failing test reported at
;; https://github.com/ruby-concurrency/concurrent-ruby/issues/534
(patches (search-patches "ruby-concurrent-ignore-broken-test.patch"