summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-12-17 15:17:06 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-12-17 15:20:11 +0100
commit6718fe7e872e78f8f15dd596fcf15c594a039bfe (patch)
treec87d4e80beb51e8fd5d9fc1796e283465a34b111 /gnu/packages/radio.scm
parent3f2bb5ce6408d7a46a7c163fa4550dfdec0bd84b (diff)
downloadguix-patches-6718fe7e872e78f8f15dd596fcf15c594a039bfe.tar
guix-patches-6718fe7e872e78f8f15dd596fcf15c594a039bfe.tar.gz
gnu: js8call: Remove workaround.
* gnu/packages/radio.scm (js8call)[arguments]: Remove 'work-around-runtime-bug' phase.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 0aa06eb43a..cdef088a07 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1224,19 +1224,7 @@ weak-signal conditions.")
(("DESTINATION /usr/share")
(string-append "DESTINATION "
(assoc-ref outputs "out")
- "/share")))
- #t))
- (add-after 'fix-paths 'work-around-runtime-bug
- (lambda _
- ;; Some of the programs in this package fail to find symbols
- ;; in libm at runtime. Adding libm manually at the end of the
- ;; library lists when linking the programs seems to help.
- ;; TODO: find exactly what is wrong in the way the programs
- ;; are built.
- (substitute* "CMakeLists.txt"
- (("target_link_libraries \\((.*)\\)" all libs)
- (string-append "target_link_libraries (" libs " m)")))
- #t))
+ "/share")))))
(add-after 'unpack 'fix-hamlib
(lambda _
(substitute* "CMake/Modules/Findhamlib.cmake"
@@ -1246,8 +1234,7 @@ weak-signal conditions.")
set (ENV{PKG_CONFIG_PATH} \"${__pc_path}\")"))
(substitute* "HamlibTransceiver.hpp"
(("#ifdef JS8_USE_LEGACY_HAMLIB")
- "#if 1"))
- #t)))))
+ "#if 1")))))))
(synopsis "Weak-signal ham radio communication program")
(description
"JS8Call is a software using the JS8 digital mode (a derivative of the FT8