summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-12-17 15:12:30 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-12-17 15:20:11 +0100
commit3f2bb5ce6408d7a46a7c163fa4550dfdec0bd84b (patch)
treef3f1bd10f1e462c7eb99554fe3152286a40dfc5d /gnu/packages/radio.scm
parenta53617391121cb8dc8484ede73a37623e198432b (diff)
downloadguix-patches-3f2bb5ce6408d7a46a7c163fa4550dfdec0bd84b.tar
guix-patches-3f2bb5ce6408d7a46a7c163fa4550dfdec0bd84b.tar.gz
gnu: wsjtx: Update to 2.5.2.
* gnu/packages/radio.scm (wsjtx-hamlib, wsjtx): Update to 2.5.2. [arguments]: Remove 'work-around-runtime-bug' phase.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm23
1 files changed, 5 insertions, 18 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 4a9a6f60c3..0aa06eb43a 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1068,7 +1068,7 @@ users.")
(package
(inherit hamlib)
(name "wsjtx-hamlib")
- (version "2.3.1")
+ (version "2.5.2")
(source
(origin
(method git-fetch)
@@ -1077,7 +1077,7 @@ users.")
(commit (string-append "wsjtx-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0m4yzjcqs7a1w4lghyyckpkiy96jxdjijddxarqr3a37cl2rz23j"))))
+ (base32 "1bgf7bz2280739a7ip7lvpns0i7x6svryxfmsp32cff2dr146lz3"))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -1150,7 +1150,7 @@ instances over the network, and general QSO and DXpedition logging.")
(define-public wsjtx
(package
(name "wsjtx")
- (version "2.3.1")
+ (version "2.5.2")
(source
(origin
(method git-fetch)
@@ -1159,7 +1159,7 @@ instances over the network, and general QSO and DXpedition logging.")
(commit (string-append "wsjtx-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0mdr4l7zii08615yn7z91spnvnqm5i9390bra9lz3aqyxrsiim91"))))
+ (base32 "01346f2x3jc0gbzdi7ihzr9rxibnbzn31ix0879qfavrv8l31k1s"))))
(build-system qt-build-system)
(native-inputs
(list asciidoc gfortran pkg-config qttools ruby-asciidoctor))
@@ -1173,20 +1173,7 @@ instances over the network, and general QSO and DXpedition logging.")
("qtmultimedia" ,qtmultimedia)
("qtserialport" ,qtserialport)))
(arguments
- `(#:tests? #f ; No test suite
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'work-around-runtime-bug
- (lambda _
- ;; Some of the programs in this package fail to find symbols
- ;; in libm at runtime. Adding libm manually at the end of the
- ;; library lists when linking the programs seems to help.
- ;; TODO: find exactly what is wrong in the way the programs
- ;; are built.
- (substitute* "CMakeLists.txt"
- (("target_link_libraries \\((.*)\\)" all libs)
- (string-append "target_link_libraries (" libs " m)")))
- #t)))))
+ `(#:tests? #f)) ; No test suite
(synopsis "Weak-signal ham radio communication program")
(description
"WSJT-X implements communication protocols or modes called FT4, FT8,