summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-06-05 23:25:22 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-06 00:25:49 +0200
commit0855fd3de526c4b8e5c3fd523ee51279be8d391b (patch)
treefdadf4b8d76e6e65349e455078b7f29625f71714 /gnu/packages/radio.scm
parentee586c9437b59093603804e88410f1365c12d3b7 (diff)
downloadguix-patches-0855fd3de526c4b8e5c3fd523ee51279be8d391b.tar
guix-patches-0855fd3de526c4b8e5c3fd523ee51279be8d391b.tar.gz
gnu: Add soapyairspyhf.
* gnu/packages/radio.scm (soapyairspyhf): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 0bc335df95..60c0a2eee8 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -287,6 +287,31 @@ with this package. E.g.: @code{(udev-rules-service 'airspyhf airspyhf)}")
defined radio hardware devices with a common API.")
(license license:boost1.0)))
+(define-public soapyairspyhf
+ (package
+ (name "soapyairspyhf")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pothosware/SoapyAirspyHF")
+ (commit (string-append "soapy-airspyhf-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04krqinglgkjvx7klqik6yn8rb4mlpwzb6zvnmvm7szqci2agggz"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("airspyhf" ,airspyhf)
+ ("soapysdr" ,soapysdr)))
+ (arguments
+ `(#:tests? #f)) ; No test suite
+ (home-page "https://github.com/pothosware/SoapyAirspyHF/wiki")
+ (synopsis "SoapySDR Airspy HF+ module")
+ (description "This package provides Airspy HF+ devices support to the
+SoapySDR library.")
+ (license license:expat)))
+
(define-public soapyhackrf
(package
(name "soapyhackrf")