summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-06-05 23:19:04 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-06 00:25:49 +0200
commitee586c9437b59093603804e88410f1365c12d3b7 (patch)
tree3fe42d488c0dabdb917b42dcba9c4f8c928a0180 /gnu/packages/radio.scm
parent59ce8276182891919baad2c306c1d632fff3e7e6 (diff)
downloadguix-patches-ee586c9437b59093603804e88410f1365c12d3b7.tar
guix-patches-ee586c9437b59093603804e88410f1365c12d3b7.tar.gz
gnu: Add soapyrtlsdr.
* gnu/packages/radio.scm (soapyrtlsdr): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 18545bae79..0bc335df95 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -312,6 +312,31 @@ defined radio hardware devices with a common API.")
"This package provides HackRF devices support to the SoapySDR library.")
(license license:expat)))
+(define-public soapyrtlsdr
+ (package
+ (name "soapyrtlsdr")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pothosware/SoapyRTLSDR")
+ (commit (string-append "soapy-rtl-sdr-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dlnryj6k20pk7w7v4v13y099r7ikhvlzbgzgphmi5cxkdv0shrd"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("rtl-sdr" ,rtl-sdr)
+ ("soapysdr" ,soapysdr)))
+ (arguments
+ `(#:tests? #f)) ; No test suite
+ (home-page "https://github.com/pothosware/SoapyRTLSDR/wiki")
+ (synopsis "SoapySDR RTL-SDR module")
+ (description
+ "This package provides RTL-SDR devices support to the SoapySDR library.")
+ (license license:expat)))
+
(define-public chirp
(package
(name "chirp")