summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-10 15:23:53 -0400
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-28 18:08:30 +0200
commitf5fda6eeab2c27751a81857579b28aaf12a23318 (patch)
treecb269b9c6e4c65afe8c82759512e8bffdd4e5b48 /gnu/packages/qt.scm
parent0e6efd2c4a7528b7d0c0370e28258f5cbcf88d22 (diff)
downloadguix-patches-f5fda6eeab2c27751a81857579b28aaf12a23318.tar
guix-patches-f5fda6eeab2c27751a81857579b28aaf12a23318.tar.gz
gnu: QtWebKit: Fix building with Python 3.9.
* gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/qt.scm (qtwebkit)[source]: Use it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f80ea336d8..4482d38a98 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2624,7 +2624,8 @@ different kinds of sliders, and much more.")
(sha256
(base32
"1rm9sjkabxna67dl7myx9d9vpdyfxfdhrk9w7b94srkkjbd2d8cw"))
- (patches (search-patches "qtwebkit-pbutils-include.patch"))))
+ (patches (search-patches "qtwebkit-pbutils-include.patch"
+ "qtwebkit-fix-building-with-python-3.9.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("perl" ,perl)