summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-08-10 15:23:53 -0400
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-28 18:08:30 +0200
commitf5fda6eeab2c27751a81857579b28aaf12a23318 (patch)
treecb269b9c6e4c65afe8c82759512e8bffdd4e5b48 /gnu
parent0e6efd2c4a7528b7d0c0370e28258f5cbcf88d22 (diff)
downloadguix-patches-f5fda6eeab2c27751a81857579b28aaf12a23318.tar
guix-patches-f5fda6eeab2c27751a81857579b28aaf12a23318.tar.gz
gnu: QtWebKit: Fix building with Python 3.9.
* gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/qt.scm (qtwebkit)[source]: Use it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch35
-rw-r--r--gnu/packages/qt.scm3
3 files changed, 38 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 11b002b66e..c620c068ee 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1657,6 +1657,7 @@ dist_patch_DATA = \
%D%/packages/patches/quassel-qt-514-compat.patch \
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
%D%/packages/patches/qtwebkit-pbutils-include.patch \
+ %D%/packages/patches/qtwebkit-fix-building-with-python-3.9.patch \
%D%/packages/patches/randomjungle-disable-static-build.patch \
%D%/packages/patches/rapicorn-isnan.patch \
%D%/packages/patches/rapidjson-gcc-compat.patch \
diff --git a/gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch b/gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch
new file mode 100644
index 0000000000..9f9674de33
--- /dev/null
+++ b/gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch
@@ -0,0 +1,35 @@
+Fix building with Python 3.9:
+
+https://github.com/qtwebkit/qtwebkit/issues/993
+
+Patch copied from upstream source repository:
+
+https://github.com/qtwebkit/qtwebkit/commit/78360c01c796b6260bf828bc9c8a0ef73c5132fd
+
+From 78360c01c796b6260bf828bc9c8a0ef73c5132fd Mon Sep 17 00:00:00 2001
+From: Konstantin Tokarev <annulen@yandex.ru>
+Date: Wed, 3 Jun 2020 15:01:42 +0300
+Subject: [PATCH] Fix compilation with Python 3.9: avoid passing encoding to
+ json.load()
+
+In Python 2.7 UTF-8 is assumed by default, while in Python 3 this argument
+is not supported.
+
+Change-Id: Ic459d60a6b20bc1838d8771bc36ac41614fe61a9
+---
+ Source/JavaScriptCore/generate-bytecode-files | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Source/JavaScriptCore/generate-bytecode-files b/Source/JavaScriptCore/generate-bytecode-files
+index c5dab429c7b0f..af3431275ecf9 100644
+--- a/Source/JavaScriptCore/generate-bytecode-files
++++ b/Source/JavaScriptCore/generate-bytecode-files
+@@ -163,7 +163,7 @@ if __name__ == "__main__":
+ initBytecodesFile = openOrExit(initASMFileName, "w")
+
+ try:
+- bytecodeSections = json.load(bytecodeFile, encoding = "utf-8")
++ bytecodeSections = json.load(bytecodeFile)
+ except:
+ print("Unexpected error parsing {0}: {1}".format(bytecodeJSONFile, sys.exc_info()))
+
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f80ea336d8..4482d38a98 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2624,7 +2624,8 @@ different kinds of sliders, and much more.")
(sha256
(base32
"1rm9sjkabxna67dl7myx9d9vpdyfxfdhrk9w7b94srkkjbd2d8cw"))
- (patches (search-patches "qtwebkit-pbutils-include.patch"))))
+ (patches (search-patches "qtwebkit-pbutils-include.patch"
+ "qtwebkit-fix-building-with-python-3.9.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("perl" ,perl)