summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-21 10:07:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-28 09:52:46 +0200
commit852a5692bbed1f2d23c0e47a7cdfb2a604a8f8b3 (patch)
tree1f0f22d8ed2b05c27d5b0140793118e533374cc2 /gnu/packages/qt.scm
parent1f71daf499c1c0708f56cd4623d07082a355fff3 (diff)
downloadguix-patches-852a5692bbed1f2d23c0e47a7cdfb2a604a8f8b3.tar
guix-patches-852a5692bbed1f2d23c0e47a7cdfb2a604a8f8b3.tar.gz
gnu: qt@4: Use invoke.
* gnu/packages/qt.scm (qt@4)[arguments]: Use invoke.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm88
1 files changed, 44 insertions, 44 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index b28e358b04..d487699827 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -433,50 +433,50 @@ system, and the core design of Django is reused in Grantlee.")
(substitute* "src/corelib/global/global.pri"
(("/bin/ls") (which "ls")))
- (zero? (system*
- "./configure"
- "-verbose"
- "-prefix" out
- "-nomake" "examples demos"
- ;; Note: Don't pass '-docdir' since 'qmake' and
- ;; libQtCore would record its value, thereby defeating
- ;; the whole point of having a separate output.
- "-datadir" (string-append out "/share/qt-" ,version
- "/data")
- "-importdir" (string-append out "/lib/qt-4"
- "/imports")
- "-plugindir" (string-append out "/lib/qt-4"
- "/plugins")
- "-translationdir" (string-append out "/share/qt-" ,version
- "/translations")
- "-demosdir" (string-append out "/share/qt-" ,version
- "/demos")
- "-examplesdir" (string-append out "/share/qt-" ,version
- "/examples")
- "-opensource"
- "-confirm-license"
- ;; explicitly link with dbus instead of dlopening it
- "-dbus-linked"
- ;; Skip the webkit module; it fails to build on armhf
- ;; and, apart from that, may pose security risks.
- "-no-webkit"
- ;; don't use the precompiled headers
- "-no-pch"
- ;; drop special machine instructions not supported
- ;; on all instances of the target
- ,@(if (string-prefix? "x86_64"
- (or (%current-target-system)
- (%current-system)))
- '()
- '("-no-mmx"
- "-no-3dnow"
- "-no-sse"
- "-no-sse2"))
- "-no-sse3"
- "-no-ssse3"
- "-no-sse4.1"
- "-no-sse4.2"
- "-no-avx")))))
+ (invoke
+ "./configure"
+ "-verbose"
+ "-prefix" out
+ "-nomake" "examples demos"
+ ;; Note: Don't pass '-docdir' since 'qmake' and
+ ;; libQtCore would record its value, thereby defeating
+ ;; the whole point of having a separate output.
+ "-datadir" (string-append out "/share/qt-" ,version
+ "/data")
+ "-importdir" (string-append out "/lib/qt-4"
+ "/imports")
+ "-plugindir" (string-append out "/lib/qt-4"
+ "/plugins")
+ "-translationdir" (string-append out "/share/qt-" ,version
+ "/translations")
+ "-demosdir" (string-append out "/share/qt-" ,version
+ "/demos")
+ "-examplesdir" (string-append out "/share/qt-" ,version
+ "/examples")
+ "-opensource"
+ "-confirm-license"
+ ;; explicitly link with dbus instead of dlopening it
+ "-dbus-linked"
+ ;; Skip the webkit module; it fails to build on armhf
+ ;; and, apart from that, may pose security risks.
+ "-no-webkit"
+ ;; don't use the precompiled headers
+ "-no-pch"
+ ;; drop special machine instructions not supported
+ ;; on all instances of the target
+ ,@(if (string-prefix? "x86_64"
+ (or (%current-target-system)
+ (%current-system)))
+ '()
+ '("-no-mmx"
+ "-no-3dnow"
+ "-no-sse"
+ "-no-sse2"))
+ "-no-sse3"
+ "-no-ssse3"
+ "-no-sse4.1"
+ "-no-sse4.2"
+ "-no-avx"))))
(add-after
'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)