summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-21 10:04:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-28 09:52:38 +0200
commit1f71daf499c1c0708f56cd4623d07082a355fff3 (patch)
tree91d85aefd6696f18b6312ea7ef5d4ec504c4c55c /gnu/packages/qt.scm
parent3ea61f9642e0552bde145b823292445b4172e6bd (diff)
downloadguix-patches-1f71daf499c1c0708f56cd4623d07082a355fff3.tar
guix-patches-1f71daf499c1c0708f56cd4623d07082a355fff3.tar.gz
gnu: qt@4: Update build config.
* gnu/packages/qt.scm (qt@4)[arguments]: Substitute hardcoded '/bin/ls' invocation. Add configure-flags to not build the examples or demos. Don't use the precompiled headers.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index b6105faa91..b28e358b04 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -430,11 +430,14 @@ system, and the core design of Django is reused in Grantlee.")
(doc (assoc-ref outputs "doc")))
(substitute* '("configure")
(("/bin/pwd") (which "pwd")))
+ (substitute* "src/corelib/global/global.pri"
+ (("/bin/ls") (which "ls")))
(zero? (system*
"./configure"
"-verbose"
"-prefix" out
+ "-nomake" "examples demos"
;; Note: Don't pass '-docdir' since 'qmake' and
;; libQtCore would record its value, thereby defeating
;; the whole point of having a separate output.
@@ -457,6 +460,8 @@ system, and the core design of Django is reused in Grantlee.")
;; Skip the webkit module; it fails to build on armhf
;; and, apart from that, may pose security risks.
"-no-webkit"
+ ;; don't use the precompiled headers
+ "-no-pch"
;; drop special machine instructions not supported
;; on all instances of the target
,@(if (string-prefix? "x86_64"